Streaming live at 10am (PST)

Embed randomly switching on click


#1

I’m really not sure how to describe this issue beyond the subject.

http://wild-hog-canoe-race.webflow.io/

If you click on “register” on any class, you are able to start typing in your information. But, if you click on anything beyond the Mixed class (try, parent/youth, youth, senior, or women’s), as soon as you click on any field to begin entering your info, it switches to the Mixed class, which is an entirely different embed!

https://preview.webflow.com/preview/wild-hog-canoe-race?preview=e658333d617126604c9e9f52f598f7de

I built this a little over a year ago, and I never received any reports of this issue until just now. I have not changed anything about how that embed switches in the meantime.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Sometimes typing these things about can help you think through the issue and solve it.

I had, apparently at some point, selected the “Mixed” class embed and assigned the interaction that was supposed to be assigned to the Mixed class registration button (which swaps the embed). To create the following embeds, I was just copy/pasting the embed, and it was bringing that interaction right along with it.

I’m guessing no one even noticed it last year and they just ended up registered as the wrong class.

I’ll just let this thread stand for posterity and to suggest that when you’re trouble-shooting, it would be nice to be able to see where an interaction is being used, without having to click on every element, and then going over to the interactions pane.


#3

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.