Streaming live at 10am (PST)

Endless Reload in Firefox


#1

Hey Guys,

has anyone experienced this annoying reload that only appears in Firefox?
Looking to find the error since two weeks, can’t figure anything out why
this only happens in Firefox… It seems stuck between two redirects or something,
but we don’t have any…

Here’s the published site (works in Chrome & Safari, not in Firefox): https://www.ismanundpartner.com/

Here is my site Read-Only:
https://preview.webflow.com/preview/ismanundpartner?preview=d1e68d5fb2a177b06f6aea69818e22cc

Thanks for all,
David


#2

Hello David!

Thanks for reaching out, and we’re happy to help.

This certainly seems like strange behavior in Firefox, and we’ll need a little more information to determine the cause. It looks like it’s loading for me in Firefox [just once, correctly]:

First, could you set your "www’ subdomain as default as recommended in our DNS setup guide:

Afterwards, please reload your site in Incognito Mode [with a clear browser cache]. If you still see the behavior, would you tell me a little bit more about the reloading behavior, the pages affected, and provide this information for us to troubleshoot?

  • Let me know what browser version you’re using by sending me your browser information from this page.
  • Log into Webflow take a screenshot when you’ve reproduced the error while using Incognito mode with browser extensions turned off.

Thanks in advance, and we’ll be standing by for your reply!


#3

Hey Andrew, thanks a lot for the time you’re taking! Really appreciate you looking into this!

• Setting www as default domain, hasn’t helped. The error still occurs.
• Using Firefox in Incognito Mode and with a clear browser cache doesn’t help either, I have no Browser extensions installed, but this wouldn’t be a solution, because it seems there are a bit more people who have the problem (client told me friends of him can’t use the site)

-> I use Firefox Quantum, the newest release – Version 60.0.2

In the bottom left corner it says again and again (flickering): “Waiting for uploads-ssl.webflow.com”, MacBook really runs hot and seems to explode if I don’t quit the page haha (newest MacBook on the market). I know that Firefox is an outdated browser, but many people use it still and many of my client’s partners and his clients seem to experience the issue.

Here’s a screencast of the issue (use it without the " ", forum can’t play the video), where you see: The font doesn’t load, I can’t scroll (basically I can but it throws me back to the top), the pictures are not loading and it seems to get redirected. Any idea? Safari and Chrome are totally fine.

Thank you! Cheers,
// David

https://www.dropbox.com/s/l2waycvudfhtjej/Webflow_Issue_Isman-and-Partner.mp4?dl=0


#4

Hello David!

Thanks for the additional information!

It looks like I can reproduce this in Firefox if I set my language to DE, and I can see this line of code in the Custom Code for your homepage, under Page Settings -> Custom Code in the Designer:

else if(language == "de" || language == "de-AT" || language == "de-LI" || language == "de-CH" || language == "de-LU"){window.location.href = "https://www.ismanundpartner.com";}

When you or your clients are visiting your site’s homepage with de, de-AT, de-LI, or de-CH as your language in Firefox, it’s redirecting them from your homepage to your homepage infinitely.

If you delete that line, the site will work as expected. You can add that as a script to the English page, just in case one of your users ends up there and needs to be redirected to the German version.

Please let me know if you have other questions – I’m always happy to help!

- Andrew


#5

Andrew it worked! Thanks so much!
Totally appreciate your help.

I actually set this code 2 Months ago, the reason why: The website exists in 2 languages:
English & German, and I wanted that the right language sets automatically based on the language code the user’s browser has. Since your from the Webflow Team, may I ask you this follow up question?

Is there a way in Webflow or a custom code that’s not running endless (haha) that the language can be detected automatically and send the user to the specific site?

Thanks man for looking into this so closely, i don’t take this for granted!
Have a nice day!

/ David


#6

Great question @davidk77!

Because most users will end up on your German homepage, you can have the English redirect there [and not the German redirect].

On the English page, add the redirect script to take German speakers to the English page. This will prevent endless reloads. You had the right code, but the redirect-to-German just needs to be moved to the right page.

In the future, this will be even easier. We’ve entered the planning stage for multi-language sites, and we hope to start development this year. You can learn more here: https://wishlist.webflow.com/ideas/WEBFLOW-I-58

Please let me know if you have other questions – I’m always happy to help!

- Andrew