Streaming live at 10am (PST)

Entire website speed is very slow

Hi all, I am having an issue with our website where the load speed seems extremely slow. I reached out to webflow and they told me to remove unused styles. That didn’t make a significant difference. The weird thing is even if it’s a blank page the load speed is as slow as the homepage with all the content. Any insight would be greatly appreciated.

Thank you so much.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

3 Likes

Good looking site! My gut is that it’s tied to the video. What happens when you publish it to the temporary domain? Is it still slow then? You could publish to the temporary domain, then head to the Google Pagespeed insights and see what it says… usually a good way to identify when things are out of place. My gut is that it’s somehow tied to the video. There seems to be a big difference between how videos render in the temporary hosted domain and the “view” within the designer for me.

1 Like

@Jpujol Welcome to the very fine Webflow Forum.
This might help you: https://developers.google.com/web/fundamentals/performance/lazy-loading-guidance/images-and-video/
Do you have a published site I could look at?
Maybe I can have a look for you.

That’s my quick question. Would there be a speed diffence between a published site, and just hitting the “preview eyeball” in teh designer of an un-edited site? I noticed his site is not published, and I thought I had encountered what I just described.

1 Like