Streaming live at 10am (PST)

"ERR_TOO_MANY_REDIRECTS" Root Domain Error

#1

Hi,
I am desperately trying to get my root domain working. It works for about 5 to 10 minutes and then I get this error “ERR_TOO_MANY_REDIRECTS” . I have noticed that removing and re-adding the CNAMES in my DNS manager makes it work again but then, only for a short period of time.

My domain is from godaddy and i am using cloudflare as my dns manager.

I added two records :
CNAME - www - proxy-ssl.webflow.com
CNAME - @ - proxy-ssl.webflow.com


In the crypto section of cloudflare, i have changed the SSl to full strict.

I already contacted webflow support but they only referred me to these articles which I already knew about:


My domain name set with “www” as default works but this is not what I want.

any help would be greatly appreciated
thank you

https://preview.webflow.com/preview/studiopulpe?utm_source=studiopulpe&preview=213b609b96f08d1b45b5ee5352fec989

unlisted #2
#3

Hi @Felix_Rousseau, I set the post to unlisted so that I can help privately, could you please let me know if you are having any issues with the custom domain still?

If you are using SSL in Webflow, you will need to set the SSL in cloudflare to flexible.

Let me know if there is something I can do further to assist.

My best,
Dave

#4

Hi @cyberdave ,
yes i am still trying to figure out how to use my custom domain. I reached out to cloudflare support team and this is what they were able to see :

I will set the crypto to flexible see if it works but i already tried yesterday. I have set up Automatic HTTPS Rewrites and Always Use HTTPS on also.

thanks for your help !

#5

I got it working once again but only for 10 minutes till the error ‘‘too many redirections’’ pops up.

#6

Hi @Felix_Rousseau

I tested your site once more and it appears the root domain isn’t configured properly.

You’ll need to make sure you have 2 A records in your DNS settings like this:

2 A records:
@ → 34.193.69.252
@ → 34.193.204.92

Currently you have 3 A records pointing to IP addresses that are interfering here. These three can be deleted: https://www.whatsmydns.net/#A/studiopulpe.com

After that you should be good to go!

#7

Is it not those 2 A records that simply redirect to the “www” domain ? Currently, I don’t have any A records. Only two CNAMES. I already tried adding them and it did not work.

I will try again !

#8

I uploaded a new project version to my domain and it is currently working. I am waiting to see if the error comes back. (With the two CNAMES)

#9

Still not working with the root domain…

#10

Hi @Felix_Rousseau

It appears https://studiopulpe.com/ is now redirecting to https://www.studiopulpe.com/ — is this what you were expecting?

#11

No I want my root domain to appear.
https://www.studiopulpe.com/ should redirect to https://studiopulpe.com/ .

I can get it to work only if i use the cname flattening method. Those two A-records redirect to the “www”.

I have set as default the full domain name. If i use as default the root domain, it won’t work with those records…

1 Like
#12

I can maybe export my dns settings and retry with no other records added.
It might be interfering with the mx records for my email ?
I don’t understand why it works for only 10 minutes .

#13

That’s my mistake here for misunderstanding your goals, @Felix_Rousseau

In this case you won’t need these 2 A records since you are using the CNAME flattening with CloudFlare.

In total you should have 2 CNAMEs:

If you have SSL enabled, you should have the following DNS records:

1 CNAME record:
www → proxy-ssl.webflow.com
@ → proxy-ssl.webflow.com

After making this change let me know and I’ll forward this over to our backend engineers to confirm everything is set up correctly.

Thanks for your patience! :bowing_man:

#14

@Brando I already did. It works for only 10 minutes and then i get this error : ERR_TOO_MANY_REDIRECTS.

I really tried everything I could as this point.

#15

@Brando can you transfer me to your backend engineer ?

#16

Hi @Felix_Rousseau

I checked our support email client and it looks like you’ve reached out there as well and Andrew was able to help you.

Please reach out to us via email regarding this matter if you have any other questions or issues :bowing_man:

closed #17

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.