Streaming live at 10am (PST)

Error 525 SSL handshake failed from Cloudflare


#1

I've just realized my website's down and I am being redirected to "Error 525 SSL handshake failed".

I use cloudflare in order to support SSL since Godaddy doesn't.
I am being told that -
"It appears that the SSL configuration used is not compatible with Cloudflare. This could happen for a several reasons, including no shared cipher suites. Additional troubleshooting information here."

I've emailed Cloudflare support and wanted to check here and see if anyone might know anything?

https://www.theillustratrice.com/
https://preview.webflow.com/preview/theillustratrice?preview=40d09aeacce6a56f75ca375ee1f50819

Any help much appreciated - quite urgent!!

Thanks,

Rachel


#2

Hi @theillustratrice, thanks for posting. The issue appears to be in Cloudflare as there is no public DNS records found for CNAME record on the domain www.theillustratice.com. There is also some A Records found, but they appear to be Cloudflare IPs:

I would recommend to go to Cloudflare DNS settings and check the settings:

  1. Create a CNAME record for the domain illustratice.com to point to proxy-ssl.webflow.com. If there are other A Records being used for the @ domain, remove those.

  2. Create a CNAME record for the domaind www.illustratice.com to point to proxy-ssl.webflow.com.

  3. For each CNAME record, make sure the DNS+PROXY option (the orange cloud with an arrow through it) is disabled and set to DNS only. Click the orange cloud to change this to DNS only. Right now, I think the Cloudflare proxy is turned on, which is not supported at Webflow, the domains have to be directly pointed at Webflow via public DNS.

  4. After making changes in Cloudflare, I would recommend to come back to Webflow and check that SSL is enabled, and to set the default domain for the site: http://help.webflow.com/faq/how-to-set-your-sites-default-domain

  5. Last step is to republish the site: http://help.webflow.com/lesson/publishing-your-webflow-site

If the issues persist, let me know I am here to help.


#3

@cyberdave Thank you!!!

It's up and running. Very much appreciate this - thanks again!

Rachel


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.