Streaming live at 10am (PST)

Experimental support for the Designer in Firefox


#1

If you’ve tried using the Designer in Firefox, you’ve seen a message that lets you know your site’s changes won’t be saved — instead advising you to use Chrome or Safari. For many of you, this has prompted the question, “what gives?”

Well, here’s what gives: when we began work on the Designer, we ran into an old scrollbar issue (and a few others) in Firefox that made things go a bit haywire. But, as our founder Vlad (the guy who built the first iteration of the Designer) has written:

We now have some JavaScript-based workarounds to avoid rendering native scrollbars, and it should theoretically be possible to provide Firefox support if there’s enough demand for it.

And so, in an effort to help us expand browser support for the Designer, we’re no longer blocking access to the Designer in Firefox, Edge, and other modern browsers.

Everything should save properly and work mostly well, but here’s where we need your help: as you are working in Firefox, please report any unexpected issues you run into in the experimental browsers category of our forum.

And at the same time, please vote for Firefox Designer support on the Wishlist if you’d like to see us move this project up in our development queue.

As always, thanks for your help!


Webflow Designer now works in Mozilla Firefox
WebFlow Design In Firefox and other browsers
Will Webflow support New Firefox Quantum? (For designing)
#2

Did a quick try in Firefox and got double scroll bars


#3

I can’t delete text in my Webflow project using Firefox for some reason.


#4

Misaligned designer elements. Some asset files not visable.

Running Firefox 63.0.3-0, GNU/Linux


#5

Hey @jannewassberg,

Scrollbars are indeed the reason why Webflow has not supported non-Webkit browsers for so long. Unfortunately there likely won’t be any prioritized fixes for these for some time, though knowing exactly which parts of the product have double scrollbars would be helpful for us triaging and prioritizing.


#6

Hey @rileyj_s, thanks for reporting! Are you unable to delete while selecting all content and trying to batch delete things, or by deleting character by character?


#7

@redrover :thinking: That looks to be related to a scrollbar issue. Does your OS have an option to hide scrollbars? E.g. on OSX there is an option to conditionally hide the scrollbar in http://osxdaily.com/2011/08/03/show-scroll-bars-mac-os-x-lion/ which impacts layout.


#8

@iamdustan here you go added a picture with the scroll


#9

Using Method 2 - from custom_scrollbars.uc.js I was able to set var hide_scrollbars = true; which looks to have fixed the issues.

Scroll speed is very slow.


#10

I am replying here because of the update notice. My name is Steven Brian Harris sbhwebdesign.com I am looking forward to being part of the experiment.