Streaming live at 10am (PST)

Exporting Corrupt Code


#1

Working on a project for uni, made the entire site in Webflow, now I’ve got to export this to host on my own server and the codes coming out corrupted. I’ve tired safari and chrome with the same results, the contact page comes out fine the rest of the pages are exporting in a single line of code and render with huge chunks of white space.

I’ll be able to submit the Webflow links although I’d rather have done it on my own server. (I’d have probably got a few extra marks for doing that :wink: )

Link - https://preview.webflow.com/preview/mini-punch?utm_source=mini-punch&preview=aed6e3c4419227edaaa6d47e3edb718a

Would the only fix be to entirely recreate the site? The only thing I’ve added outside of Webflow is a HTML 5 audio source that is only found on a single page, no other custom code has been added.


#2

That’s really strange.

Could you post a link to the exported code?


#3

Bit of a delay since I just submitted the Webflow link but you can see it uploaded in all its corrupted glory here; http://news.minipunch.uk

As you can see the site isn’t aligned properly and theres a ton of white space that shouldn’t be there. If you look at the contact page the page has been exported properly.


#4

One of the strangest things I’ve ever seen. There’s got to be something going on here. The source is correct, but what is being rendered has everything that is in your head tag being moved into the body. I’m not 100% sure that is what is causing all of this, but it sure can’t be helping.


#5

Stranger still, the code export on the contact page looks completely different, which is why it is loading properly. I didn’t see any custom code on the page level. Do you have anything special loading on the site level?


#6

Did you try exporting again?

Try turning your minify settings off and on again (saving and exporting between each change).

Something went haywire, that’s for sure.

When you uploaded, did everything go into a folder that is not running anything else? Were any changes made after export?


#7

Apologies for the late reply, as I said before the deadlines past now so I’m not regularly checking back here, but I really appreciate your response and it’d be great to work out what happened!

I’ve never enabled minify in my time using Webflow, to be honest I don’t bother doing it outside of Webflow either, I don’t see the value in saving such a small amount of data, I’m sure my opinion will change as soon as I run into a case that requires it!

Nope, no changes after export, tested the site on my live server straight away, noticed the problem thought the same and opened it on my computer from the folder downloaded, same results. downloaded 2-3 times again from webflow same results, removed the only bit of custom code in the site, same results. Had me baffled, didn’t have time to remake the site before my deadline so just submitted the Webflow site, annoyingly I had a subdomain set up news.minipunch.uk and I got marked download because the domain name didn’t reference news (minipunch.webfow).

I still have the project live in my webflow account, I’ve got to dash now but I’ll re-download it since time has passed and see what comes out the other end. If not this might be something the webflow team might want to check out, can’t imagine how I’d feel if I’d spent a full 40+ hours on a site for a client and this to come out the other end, having to explain to a client the prototype I’ve been showing them just needs a “little” more work would be embarrassing.


#8

Hi @Qwen,

Thanks for taking a look at this, and I wish you would’ve been able to use your exported code.

I was able to check with our engineers, and at the moment, there is a bug which affixed to a small number of projects which introduces whitespace into the export.

The solution at the moment, is to first unminify the site after export using a tool like unminify.com, then the exported files should work ok.

Though I do not have a timeline on when a fix will be available, we’ll be happy to let you know as soon as possible.

Thanks again for letting us know, and thanks for your patience :bowing_man: