Streaming live at 10am (PST)

Extra space at the top of the page when viewd in Editor


#1

I'm not sure whether this really is a bug or something to do with this specific site.

When viewing in Editor white space is added to the very top of the website. No Google Analytics is installed. I'bve tried removing the AddThis script, but that doesn't clear it.

What is the reason?

https://preview.webflow.com/preview/absolute-return-partners?preview=ceaa5a4ce55d99e96359a124d66951e5

Many thanks.


#2

Hi there,

Could you possibly provide a screenshot of where you're seeing extra white space?

Just took a look on my computer (Mac Pro 5,1) and can't see any white space at the top, either in the designer / editor view or when it is in preview mode. Obviously I can't see the published page but wouldn't think they'd be too different.

Are you perhaps getting the 'white space' when you are scrolling the page?

If so then a lot of browsers do (for some reason - I'm not sure why - hopefully someone else can answer this one?) scroll further up and down and also left and right than the site should allow. Some sort of built in browser scrolling happening there though and not always the site design.

Anyway, if you could provide a screenshot or maybe even a screen-recording which would really help too.

Best wishes,

Mark


#3

EDIT TO ADD - Sorry about the grey background. Don't worry, that's not your site doing weird things. For some reason if you have your screen dimmed then you record using the app I'm using it records dimmed.

Actually I've just taken a screen-recording myself of what I mean :

When I scroll the page as in that animation, is that the sort of thing you're referring to perhaps?

If so then that's the browser doing that and I'm not entirely certain there's much that can be done about it. Hopefully I'm wrong on that and someone else can tell you that but it definitely happens on a lot of sites that I browse to and they can't all be coded wrong :wink:

Best wishes,

Mark


#4

Thanks for taking a look @Mark_Bowen.

I don't think it's what you've been looking at. The space appears permanantly whenever in editor view.

Of course I should have provided a screenshot before. It's below.

When I insoect the code, I notice that the following DIV seems to have a height. Might that be the reason?

<div class="w-editor-bem-EditorApp ">

--
Here the screenshot of the actual space:

Thank you for any help!


#5

Hi @spirelli,

This is expected behavior when the Editor is open.

It's to adjust for elements in the Editor.

https://cl.ly/3r3s1Z2Z3P20

I hope this helps! :slight_smile:


#6

From the screenshot you've taken there I can see that this isn't in the editor but when I visit the URL showing in the screenshot - http://arp.truedesign.co.uk I don't see any space at the top of the screen when the page loads.

Are you getting that space when you scroll up the page? If so then it is a browser issue as a few of them do that when you scroll too far and I'm not really too sure what can be done about it.

If however it's not when you're scrolling but rather just showing like that when you initially load the page then I'd advise trying first of all in a different browser and then try in your browser which is having the problems but with all extensions turned off and try in an incognito / private browser window to see if that has any effect.

Hope that helps a bit.

Best wishes,

Mark


#7

Hi @Mark_Bowen,

I was logged into the Editor for this screenshot :slight_smile:


#8

Sorry should have said that I was referring to spirelli's screenshot and not yours.

It looks like he's seeing the problem on a non webflow URL.

Best wishes,

Mark


#9

Out of interest though, what is that settings cog that you have there in your screenshot as Webflow doesn't do that on any sites I've worked on?

Best wishes,

Mark


#10

Hi @Mark_Bowen

Sorry for the miscommunication there :wink:

You can access that by clicking on Editor (https://cl.ly/2E3v0G0w333C) when in your site settings, or by adding ?edit to the end of your Webflow URL :slight_smile:


#12

Thank you for clarifying that, @Brando. Makes sense but doesn't look good. It may be 'expected behaviour' to you and anyone else who knows, but to noone else, and this rest thinks that something's broken. That'll include the contributors (the people who really own the site).It impats ont the apparance of the design.

My suggestion would be to do something about it that gets around that – to make Webflow even more great than it aleady is and have that Editor appearance just skleek.

There should be some script you can write that places the cog wheel or pencil icon at the bottom of the box if it's too close to the top edge. That'd be fab.


#13

We agree 100%, and we're looking into it :slight_smile:


#14

@jmw Thanks for looking into it
(and apologies for the manny errors in my previous message)

Cheers.


#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.