Streaming live at 10am (PST)

Extra white space on mobile

Hi, all of my pages have extra white space on right side on mobile for some reason: https://sparshs-dandy-project.webflow.io. I don’t have any negative margins and all most component margins are set to auto. I tried changing body:overflow attribute to hidden but on doing that vertical scroll stops working. Could anyone please take a look and help with this issue? Thanks in advance!


Here is my site Read-Only: https://sparshs-dandy-project.webflow.io

1 Like

Please post your read only link https://university.webflow.com/lesson/share-your-project-and-invite-collaborators

Hey Dave, sorry wrong link, here’s the read only: https://preview.webflow.com/preview/sparshs-dandy-project?utm_medium=preview_link&utm_source=designer&utm_content=sparshs-dandy-project&preview=0b4be530916bcaa82d4c22b4c466dabc&pageId=5f43e0d9470b977989d35b3e&mode=preview

Theres a whole bunch of things going on with your site right now that may be causing it. Currently your menu is unreadable as everything is overlapping. I can’t see any white space though. Maybe rework your layout and come back if you still have the issue?

Hi @DFink, sorry I don’t follow what you mean. I checked the menu and it loads fine, and I can see the white space on mobile, like this:

This is why I was recommending modifying your whole site structure which may fix the issues you are having. I am unable to replicate that white space.

Screen Shot 2020-09-23 at 1.29.17 PM

I am having the exact same issue :frowning: when ever I drag to the iPhone X size/option, it is leaving me with extra white space on the right of my site, but not in any other screen sizes larger than that.

Can someone please PLEASE help me as it’s driving me crazy! haha :slight_smile:

READ ONLY LINK

Hi @DFink I think that’s some kind of rendering issue with the read only link. Both in my preview and on the actual URL, it loads just fine. Also as you can see, the white space exists:

Could you take a look at the url (https://sparshs-dandy-project.webflow.io/demo-restro) and see if you can spot anything causing the white space to occur there?

As I mentioned before, I have definitely not used -ve margins anywhere.

Thanks

I cannot see the white space at all. I’m sorry! Did you check to see if any items have a fixed width?

That’s weird, even on the URL (https://sparshs-dandy-project.webflow.io/demo-restro)? Yes I do have elements with fixed width, is that a potential cause?

Yeah, if you have fixed width, that is likely why, try using percentages instead.

Done, but the issue still persists. @DFink

1 Like

Hello @Sparsh_EMC

Try doing the following:

Go to your .container class on mobile > remove margins

Tell me if there’s an improvement

Piter :webflow_heart: