Streaming live at 10am (PST)

FAQ Trigger Hide & Show


#1

Hi,

I have two questions:
On my FAQ page I am having the interaction of hiding the answer and then showing it by clicking the question. On the loaded screen I want all the answers hidden. I have essentially done this but when I click one of the answers all of the questions answers open. I would like each answer to open individually when the corresponding question has been clicked.

When clicking the question to hide the answer after it has been opened it has a massive jump right at the end. How do I fix this?

https://preview.webflow.com/preview/alicias-marvelous-site-45-ae806824bacd0?preview=33d75684e38af120ffbf3be2b446bc6d

Thanks so much,
Alicia


#2

Hello @leesh

I created the basics of your request here:

https://preview.webflow.com/preview/testingplayground?preview=eaf772107fb9b54c77952adb2d2647e2

Go to "Show and Hide elements" page to see how is built


#3

Thank you so much! This was very helpful.

It is still a little jumpy. Yours flows so nicely. Would you mind glancing one more time?


#4

It is strange bc the majority of them have that teensy initial jerk from the question below moving, and then again at the end.
However this question "What are some signs that my child might need speech therapy?" is so smooth. I can't figure out what is different on that one compared to the others.


#5

You can delete the bottom margin and that eliminates the jumping behaviour.


#6

Thank you so much for taking the time to help me <3 It worked perfectly.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.