Streaming live at 10am (PST)

Firefox v Chrome


#1

Happy FriYay!
Whenever I design a @webflow site and publish I usually view it in Firefox, however, my latest project seem to be hitting some snags in the fox. Something about a script error and I’m like, chrome ain’t tripping so whats up homie?

Do you guys have similiar interactions? Did i overdose IX2.0 and firefox just can’t keep up?

Share your thoughts with me guys.

Cheers!


#2

Hi @andreswaby, thanks for your question. It is hard to tell without seeing viewing the published site, could you please send a link to that?

Also, to view the design to see if there are any styling changes needed, could you help to send a read-only link to the project in question? https://university.webflow.com/article/how-do-i-share-my-sites-read-only-link

Finally, a picture says a 1000 words, is it possible for you to take a screencast or screen capture of the issue to better visualize what you are seeing? Webflow uses a good tool https://getcloudapp.com

Thanks in advance


#3

Hey @cyberdave,
the site in question can be previewed HERE
check it out in your FireFox and see if you get any errors/crash. maybe its just me.:confused:

Also, READ ONLY

Cheers!


#4

I’m not seeing any errors in the console in Firefox. There are some sections that stay blank compared to Chrome. I see horizontal scroll in Chrome and Firefox.

I suspect that the issue comes from whatever is making the horizontal scroll bar show up. If the scroll trigger relies on a certain percentage of the element being visible in the viewport, but the design prevents the element from being fully visible in the viewport, this could be the issue.


#5

Hey @forresto,
Is that a tablet view? Could you also check it out on desktop?

The only interaction exception is a 15-30% scroll into view (then animate). There should be no horizontal scroll so I will revise that.

Outside of that, you’re getting no lag or errors so that must be my device with 50+ tabs that I have sucking my RAM :laughing:

Thanks!


#6

Time to restart Firefox??? :sweat_smile:

I sized the window for that screenshot to various sizes. Let me know if you figure out the horizontal scroll, and if it fixes the interactions showing up.


#7

HAHA :laughing:
I try to spring clean but it never does enough.

The horizontal scroll is probably the 1140 px container wrapper that i have for desktop but it goes to 100% on mobile devices. so that explains that :slight_smile:


#8

The more painstaking this gets, after all, I’ve refreshed, deleted and updated and I’m finally thinking that maybe Firefox can’t handle the scripting.

My scroll into views remain invisible. Some barely show up at all.

Arrgh! :sweat_smile: