Streaming live at 10am (PST)

First impressions/design feedback on homepage please 🙏🏻


#1

Hi all,

I’m mid-way(ish) through an e-commerce build. Would like some feedback on the homepage please.

http://just-jonah.webflow.io

• Is it clear to you what the website provides?
• Is the navigation/CTA clear?
• What do you like or dislike?
• Would you purchase from this store?
• Do you have any recommendations for improvement?

Feel free to have a mooch around the rest of the site (what’s there anyway) and offer any other feedback too, theres still a lot need doing so apologies if you get lost!

Thank you.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

I feel that menus shouldn’t be click to open.

The hover shadows in the “Latest additions” section doesn’t go well with your flat design on the rest of your site. Furthermore the box shadow is too large/strong.

Perhaps try to change the newsletter success message default text and background colour?

There is a horizontal scrollbar, try to fix that.

The main menu links wasn’t apparent to me as it looked like part of the logo or some tagline for the site.


#3

I hadn’t even considered hover, but having tried it I’ve just amended it.

Great point. Changed to a border colour change to orange as other elements on the site do.

This will link to a thank you page with further actions, and for analytics use

I thought it was the waves at the footer, but I’ve changed them to 100% width, and I can’t figure out what’s causing this. I may need to post a help topic on this (The Y axis interaction on mouse movement isn’t working when the page is longer than 100vh)

Great point, edited it to separate it more from the logo

.

Thank you so much for your time @samliew


#4

Try this custom code in the Site Footer Code:

<style>
body {
    overflow-x: hidden !important;
}
</style>

#5

That’s perfect.


#6

Hi @samliew

This has just stopped working and is now showing the overflow on the footer again. Any ideas on why this would happen and what I can do to correct it please?

Read only link


#7

I’m not seeing this issue.


#8

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.