Streaming live at 10am (PST)

Fixed Background only showing 'effect' in IE


#1

Advice please, I find that when I apply 'Fixed' to my background images they work fine and as expected on Desktop (Giving a nice 'pseudo parallax' effect) but only when using 'Internet explorer' and NOT in the other browsers (Chrome,Firefox,Mozilla etc) . Am I missing something really obvious or is there something else I should be doing.(I set all the parameters as according to instructions etc-'Cover','Center','Fixed' etc). Many thanks for any responses...


#2

Could you please share a public link so that we can take a look at what's wrong?

You can find out how to share a public link here.


#3

Please find link attached.( Site is very far from finished -lots more to be added and removed and changed !!)
https://webflow.com/design/micksurphlis?preview=51cf83806676f760e9474eca357f51d6
Like I said above, the fixed background images are fine in IE but they scroll in the other browsers-any help appreciated.


#4

The fixed background in the About Me page works perfectly fine in Safari 7.1 and Google Chrome 39.0.2171.95 running on Mac OS 10.9.5. I could not find any other picture that was actually set as "fixed".


#5

Thanks @collut for having a look. There are two 'Fixed' images on the 'My work' page which work as they should on IE but not on the other browsers. I just can't work out why they only work on IE(I have checked they are deffo 'fixed' in my Webflow workspace )


#6

I have had this same exact issue for a long time. It appears to be a Chrome/ other browser issue and not on Webflow. I have not found a workaround but would appreciate if anyone else has!


#7

Yes would deffo also appreciate a way around it. I have viewed many 'Webflow' websites on Chrome where the 'Fixed' background works fine and thats why I thought I was missing something to make it happen.Here's hoping smile


#8