Streaming live at 10am (PST)

Fixed Background Parallax with Slider–not working?


#1

I’m experiencing an issue with the Slider tool where my first slide image can be fixed, but the rest present a flat gray color when this option is selected, sometimes sending an image so far off center that it’s off screen.

Does anyone know why this is happening? Or is parallax just not possible with all slides in a slider?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Thanks for posting this, this definitely sounds like odd behavior.

Are you setting a background image to the slide itself? If so this may be the issue. Components in Webflow have some settings that, if changed, will cause them to not function correctly. In the case of the slider if the slides’ display / position settings are changed they may not work correctly.

I typically recommend adding a div block, setting it to 100% width and height, then setting a background image there instead. Can you please try using this structure to see if it resolves the issue?

If this doesn’t help, can you please share your Read-Only link so I can take a closer look? Can you also let me know what page and section your slider is on?


#3

Hey Brando,

While adding divs directly into the slides and setting them to fixed did cause the fixed scroll effect to work, this resulted in the slider not working, just staying on that image. I also experienced a strange error (I think because the div’s display type was screwing with the other slides) where when I tried to edit other slides, their bounding boxes would show up outside the bounds of the editing window.

I’ve since given up on this idea of this effect with fixed, changing images, and opted for the typical scroll function. But I’m sure it’s easily recreated with a 80vh slider filled with divs in each slide, with backgrounds for each div set to contain, and at least one of those div backgrounds set to “fixed.” It just completely wrecks havoc on the system, and in the end I was better off deleting the entire slider and starting over (which is a huge pain since there’s no file organization to make reselecting photos even a little easier)


#4

Thanks for letting me know @ChristianDominique – it definitely sounds like you experienced some unexpected behavior with the slider.

I think setting a slide or div within those slides to a fixed position will definitely cause some issues. I think this may just be a limitation of using a prebuilt component. That is, with the Slider component relying on specific display and position styles to maintain it structure/functionality, certain other display and position styles can’t be applied to elements nested within the slider.

Sorry you had to start over with this component. It sounds like you may have found a solution, though!


#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.