Streaming live at 10am (PST)

Flexbox not working when desktop display is turned off


#1

I feel like I reported this a couple months ago, but I can’t find the thread.

Flexbox settings work when a section is visible at all breakpoints. Once I set it to not be visible on desktop, all children just sit on the left.

https://preview.webflow.com/preview/majesticsamoyeds?preview=033641ee93f15b493cfac1e9f50b9238


Flexbox disables when desktop view disabled on element
#2

There’s nothing in the div?? I’ve not seen what you’re talking about, can you please re-create the issue and re-post your link.


#3

I gave up and did it a different way. The preview link is showing you where the project currently is, instead of where I last published it (has it always been that way?).

You can recreate the issue yourself.

Create a div and make it invisible on desktop via the Settings tab. Make it a flexbox and put some stuff inside it. The contents will not follow any flexbox settings until you turn desktop back on in the parent’s settings tab.


#4

Okay sure, but the Webflow css cascades down, so if Desktop is invisible, so will all the others.


#5

Not if you do it through the Settings tab.


Flexbox disables when desktop view disabled on element
#6

Hi @Cricitem, thanks for the report, this issue should have been previously fixed, if it is the same one, I am investigating into this, and will work to help get this fixed again.

In the meantime, do the workarounds in the original post help mentioned here: Hide section issue on mobile ?

Thanks in advance.


#7

I’m not sure if this is a bug, it seems so and I don’t recall having this issue before, but I’ve created a new project to demonstrate

here

Basically, create a div (div 1), stick another div in it (div 2), turn on flexbox on div 1 and set to center horizontal. Div 2 is now aligned and justified centered in div 1, obviously.

Now, switch to landscape or portrait mobile view. Select div 1, disable desktop view. Flex layout now turns off, and there is no way to turn it back on without enabling desktop view.

Is this intended behavior?

Thanks!


#8

Also reported here: Hide section issue on mobile

and here: Flexbox not working when desktop display is turned off


#9

Hey guy. I’ve got a newborn, so I don’t have time to watch the video, but I would assume the workaround is to just set the element as display:none on the desktop view, which is what I’ve done. That works properly and I’m really just pointing it out because it’s something that could be super frustrating for a newbie and possibly dissuade them from pursuing Webflow as an option.


#10

Hi @cyberdave ,

Experiencing this same issue today, so it doesn’t seem to have been fixed. Any status updates on a fix?

Thanks in advance.


#11

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.