Streaming live at 10am (PST)

Font weight is not working


#1

Hi

I try to upload different font weight in my project font section, but when I upload no matter is bold, normal, or like, they all looks the same.

How can I fix this, please?
I clean the cache on my browser and upload again, the same thing.

Ruby


#2

Hi @Madebymt, thanks for the post. Is it possible for you to send a screenshot of the font on the published site, and if possible the url?

Sometimes browsers will have issues to render fonts the same way, and in that case a little custom css placed in the Head of the site using Custom Code may help when the site is published.

Here is some code to add to the head of the site to see if it helps:

body {
-webkit-font-smoothing: subpixel-antialiased;
}

After adding the custom css, Republish the site.

I hope this helps.


#3

I use

html { 
    -webkit-font-smoothing: antialiased;
    -moz-osx-font-smoothing: grayscale;
}

I’ve seen this in use as well or the subpixel-antialiased – we all have preferences but occasionally, it might actually depend on the font you use.

html, html a {
    -webkit-font-smoothing: antialiased;
 -moz-osx-font-smoothing: grayscale;
    text-shadow: 1px 1px 1px rgba(0,0,0,0.004);
}

#4

Thank you so much! If that happens to my all the page, I would need to do that each time? Thanks!
R


#5

Hi @Madebymt, you can put the custom code on the Site head in the site project settings.

Here are some good resources:

Using custom code in the head and body: https://university.webflow.com/article/how-to-add-custom-head-and-body-code-to-a-webflow-site

The Custom Code tab on project settings is where you put site wide CSS.

I hope this helps.


#6

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.