Streaming live at 10am (PST)

Fonts and CSS not showing Properly on Windows OS


#1

Please assist, Fonts not loading plus things are out of place and some CSS


#2

Hi @Starlord, Could you please update the post with some more information so we can help you faster? Things like your read-only link, screenshots whether or not you are using custom fonts or built in fonts, and your environment info like Windows 8.1 and what browser you are using?

Posting guidelines can be found here: http://forum.webflow.com/t/posting-guidelines-for-the-need-help-category/8094

Thanks in advance! Cheers, Dave


#3

Hi

Thanks for your response

Here's the link below
http://mzansisfinest.webflow.com/

Im using custom fonts (Didot)
Windows 7 firefox


#4

Thanks for your update. Looking at your published site css, it looks like you are loading only the TTF versions of your custom fonts. For maximum browser compatibility, you should also upload the .otf, .woff and .eot versions of your fonts. If you do not have those fonts, you can go to a service like everythingfonts.com and generate those versions. See our custom font documentation:

http://help.webflow.com/site-settings/fonts#upload-custom-font

I hope this helps, try that, upload the missing font versions, and then save and republish your site.

Cheers, Dave


#5

Thanks for that, but will that fix the layout?


#6

Hi @Starlord, if you mean the problem with the mobile layout, I am still looking at that. This font upload only affects the font issue. Cheers, Dave


#7