Streaming live at 10am (PST)

Form action inconsistently working with Facebook set Ad Urls

Hey Webflow Community,

So today we kicked off a social media marketing campaign focused on pre-launch efforts for a Kickstarter. We’re using Webflow for our landing page with a form that pushes the email to our Mailchimp list.

The problem that I’m having is that when people are clicking the facebook ad, only about half of the time the email is getting sent to Mailchimp. The rest of the time, I get the default email from Webflow saying that a form has been submitted and have to manually add them to Mailchimp

When I preview the ad URL the form action and redirect are correct in the Code Inspector. I’m not able to find the page that has the incorrect button settings on it.

Do any of you have experience using Facebook Ads URLs and custom forms that experienced a similar issue?

Best,
Ben


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi @loschenbd,

It’s really weird that the form is randomly selecting what to pass or not, I believe you should be able to determine why some are parsing and why others are not.

Do you have the link of your project? Or are you able to share the code you did for the integration?

Right! It would be much simpler to trouble shoot if it were plain not working. But it’s been about 50-50 on the type of form submission (default or Mailchimp POST). I just attached the read-only link to the original post.

I installed a Hotjar for when we’re running ads and I’ll have some more info tomorrow. Let me know if you’d like anything more in the meantime!