Streaming live at 10am (PST)

Form element names won't save


#1

When adding check boxes or radio buttons the names of the element (say I name the checkbox “agreement” ) always reverts to "checkbox1, checkbox2, etc. IF I make the change over nd over again and randomly try different names and ID’s it will sometimes stick… but then randomly revert back. When I get the form notification it is impossible to tell what checkbox is checked if there are many of them, without a proper label. Also, I tried deleting and adding new ones, and then they show up in the wrong order - STILL incorrectly named.

Whats the issue here?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Hello @Neil_Eisenberg

Can you share your read only link please?


#3

https://preview.webflow.com/preview/ja-roofing?utm_source=ja-roofing&preview=18887f3fa75d7c57795e91a34f936eee

Sorry about that. I didn’t share it because unless you try to save the field names you cant tell it isn’t working. And you cant save using this link. But maybe you can see what else might be wrong. Thanks.


#4

Just be sure that the value is applied to the element itself and not the sub elements inside:


#5

Aaron, this really helped (except at first I didn’t realize it was looping and wondered why you kept doing the same thing over and over…lol I guess thats what I was doing, although I didn’t realize it. Appreciate your time.


#6

I’m glad I was able to help.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.