Streaming live at 10am (PST)

Form Elements return False even when checked


#1

Hello,

I have a bunch of checkbox form elements on my website (I styled them a bit differently as clickable buttons, and turned opacity to 0% for the actual checkboxes).

Sometimes when I test out the form, I randomly get some of the elements to return False even though I have them checked (seems to mainly occur when I check a lot of the elements at once ie. all of them)…this shouldn’t be happening. How can I fix this?

Link: https://preview.webflow.com/preview/jsl-marketing-fe91e4?preview=17f83186c82186ec719a84b947bab713

*Go to Request Pricing Page


#2

@rhami which form elements were you seeing this occur exactly with?

I could see someone potentially selecting one of the Project Types, selecting fields, then deselecting the project type?

I’m having trouble reproducing the behavior which you’re describing of the checkboxes returning a false value when something has been checked but maybe I’m missing something?

Thanks in advance for your help!


#3

Hey @Waldo,

For example, if I click on every single one of the checkbox elements (Website Design, Logo Design, Marketing Services…then all of the additional checkbox elements within the windows that pop up) that is a total of 27 elements.

When I click Submit, in the email I receive, all 27 of the elements should return a value of True …however, I randomly get a few elements that return False (and it differs each time I do this).

Does that make sense?


#4

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.