Streaming live at 10am (PST)

Form field not populating or able to be typed in


#1

I was testing the Contact page for the site I'm working on. The form works great in Safari and Chrome. However, in Firefox, the first two fields don't show any labels and they cannot be typed into. Does anyone know why this might be happening? Thanks!

http://green-lawn-pros.webflow.com/contact

Chrome:

Firefox:


Problem with forms in IE 11
#2

Hi @ryanjames

This happens because Firefox handles the padding differently, and doesn't leave any room for text. This only seems to affect form input fields.

If you hover over the padding control in webflow, you can see how the padding overlaps the entire input field. Perhaps try setting height and reduce padding to allow room for the text.


#3

Thank you! I'll give that a shot.


#4

It worked! Thanks so much! You saved me a lot of troubleshooting.


#5

Input fields (except textarea), look at http://huraapaarky.webflow.com/, are not editable in IE 11 (they are not disabled, you can place the cursor inside, but when you type, no character apears). The same code works well in Chrome (but not in IE 11) . Does anyone know why? Thanks.


#6

@macovam77 I've merged your question into this topic, please review above to see the fix.


#7

I'm not sure whether or not this is the same problem, but the forms on my site: http://nbtest.webflow.com/
(https://webflow.com/design/nbtest?preview=863e47123af7d68335bcb4291bc4c307) do not shot labels or field names in IE9 or less.

I've tried to give the field a class and check the padding as above, but it didnt seem to make any difference.
Suggestions?


Form input placeholder doesn't work in IE9
#8

Yeah you're right @Karl_M your labels go missing on IE. I see the screenshots here: http://www.browserstack.com/screenshots/5fe08a75859adb0416dca7dd9ce1bd2ce5830f06

And the fields have default styles. Hmm...We're going to look into it.


#9

IE9 does not support the HTML5 "placeholder" attribute, so we're looking into alternatives like http://jamesallardice.github.io/Placeholders.js/ to enable them.


#10

I have tried to add value="#" as well, but that didn't work...
thanks for looking into it!


#11