Streaming live at 10am (PST)

Form input placeholder text color will not change on the published website

Hey Webflowers,

This is going to sound like a super newbie issue, but I’ve been using Webflow for years, and I am either overlooking something or this is a bug:

No matter what I do, my form input’s placeholder text color will not change on the published website.

Note: I do not have any custom code on this website that pertains to this form. The only custom code I have is to insert the current year for my copyright date, and disabling an overflow scroll bar.

Here is the form in question with the input highlighted, called “Stripe Input.” It’s on the homepage in the last section.

In the Webflow designer, the placeholder text shows as correct, which is “White Smoke” or #f5f3f1.

However, when the site is published, the placeholder text shows as gray. There is no opacity on the placeholder text color either. I am using the most updated version of Chrome. It does not have the issue in Safari, and I have not checked Firefox.

If anyone has any suggestions, I would really appreciate the help. Hopefully I am just having a brain fart here haha.

Links:
My Read-Only Link
Published Site

Thank you for any help you can offer!

Edit: I do want to call out that I have looked around the forum for a solution, but none of the posts were for this specific issue or explained a solution to my knowledge. Here’s a couple examples of ones I looked at:
Post 1 and Post 2

Did you happen to figure out a way to get this fixed? I just took a peek at your live website and read-only link and I’m seeing the same color placeholder text on both:

image

1 Like

Hey @mikeyevin - I did not find a solution. It still appears grey on my Chrome browser. Which browser and version are you using? Maybe it’s just on my machine?

Thanks for looking!

I’m using the newest version of Chrome on Windows 10. Does the problem persist in incognito with all extensions disabled?

@mikeyevin Thanks for pointing out to me that it was working correctly on your machine. Looks like it was just something that was going on with my setup. I don’t know what the issue was, but it’s not showing anymore. Maybe cache? Even though I tried incognito and cleared cache. Now I am seeing this weird placeholder alignment on Safari browsers. Any insight? It only occurs on Safari desktop and mobile that I am aware of.

Unfortunately I don’t have an easy way to test with Safari browsers as the only Apple product I own is the iPad Pro. That said, even though I’m surprised it’s not rendering the same, I’d imagine with some custom code you may be able to target and override some of the Safari-specific styles that are being applied.

1 Like

Well thanks for looking, I appreciate it. I might try and overwrite the styles. Have a good one, and thanks again for helping me with these problems!

1 Like