Streaming live at 10am (PST)

Form POST to mailchimp re-directing to mailchimp hosted signup


#1

We have an email form on a webflow page that collects name (non-obligatory) and email. I tried to move our form from a Webflow GET form to a Mailchimp POST form (posting to a list we have on mailchimp), following the instructions in the docs for how to push to Mailchimp, but using a webflow form.

When we published the form to our customsubdomain.webflow.io, it worked fine and showed an inline success message in the page. However, when we published the exact same setup to our custom domain (lingumi.com), the form submit button redirects to a Mailchimp signup page to enter the email address (again).

Is there some kind of bug with custom domains which means the form redirects to the mailchimp hosted form by mistake? We’ve put it back to a Webflow for for now as we don’t want the redirect to happen.

The live form (currently using Webflow GET without any mailchimp tie-up) is at https://lingumi.com/gewinnspiel


#2

No issues submitting your form.

For us to help you, we must be able to repro the issue on your site.


Form POST to Wisely re-directing to Wisely hosted page
#3

It is currently, because I reverted to using the webflow GET method which saves form entries to Webflow. It’s only when I put the mailchimp POST action into the form settings that the redirect occurs. Oddly, the error only occurs on our custom domain, and not our ‘lingumi.webflow.io’ staging domain, despite being identical setups.

To reiterate, testing on the current live site will not show the redirect, as I reverted to the webflow form setup so as not to affect submissions coming in currently.

To be able to repro on the live site I’d have to revert to the Mailchimp redirect which might cause us to lose submissions as they get directed off our page so won’t follow the steps…happy to do it if someone can have a look fairly quickly though? Then I’ll just affect a few. They’re coming in at 1-2 an hour


#4

You can also clone the page and repro on the test page on your live site.


#5

Great idea :grinning: I repro’d to:
1.) https://lingumi.com/test-form
and
2.) http://lingumi.webflow.io/test-form
You’ll notice that on the test domain, it works fine, but redirects on the main page. The only thing I can see that could be causing the difference is that the webflow staging domain is http://, where our site uses https. I don’t know if that could be affecting it, just a thought


#6

Update: I dug into the HTTPS: issue, and it turns out lots of people have it with Mailchimp when running POST requests from https:// sites. This post explains what to do.

I updated our POST action URL to be https:// instead of // at the beginning. That appears to have resolved the issue of the redirect.

Would recommend updating the Webflow doc to reflect this?


#10

Hi @tobymather,

Thanks for suggesting this.

It seems that this point (to prepend https:) was already in the MailChimp setup guide.

If you have suggestions on how we could improve this, please let us know.

Thank you