Streaming live at 10am (PST)

Fullpage.js does not work on mobile

This post was flagged by the community and is temporarily hidden.

Maybe @Alvaro_Trigo can take a look?

It does work now !

I changed the custom code with

<script type="text/javascript" src="https://unpkg.com/fullpage.js/dist/fullpage.min.js"></script>

<script>
	//fullpage.js initialization
  new fullpage('#fullpage', {
    
  	verticalCentered: false,
    responsiveWidth: 1000,
    responsiveHeight: 500,
    scrollBar: true,
    easing: 'easeInOutCubic',
    css3: true,
    
    
  });
</script>

<script>
$('#fullpage').fullpage({
    onLeave: function(index, nextIndex, direction){
    var idx = Math.abs(index - nextIndex)*.250;
    $.fn.fullpage.setScrollingSpeed(idx*5000);
    }
})
</script>

@zweimillimeter you are initializing fullPage.js multiple times. You only need the first one. In fact, your second initialization won’t have any effect at all :slight_smile:

1 Like

oh really ? where ? how can I make it to initalization just once ?

Just use this:

<script type="text/javascript" src="https://unpkg.com/fullpage.js/dist/fullpage.min.js"></script>

<script>
	//fullpage.js initialization
  new fullpage('#fullpage', {
    
  	verticalCentered: false,
    responsiveWidth: 1000,
    responsiveHeight: 500,
    scrollBar: true,
    easing: 'easeInOutCubic',
    css3: true,
    
    
  });
</script>
1 Like

oh ok, what about scrolling speed ? it feels like its little bid too heavy.

Besides of that, thanks a lot ! when the website is ready to lunch I will tell my client to buy a licence ! :slight_smile:

You can control the scrolling speed by using the scrollingSpeed option.