Streaming live at 10am (PST)

Fullpage.js Slides down till end


#1

Hi guys. I’m trying to add simple fullpage.js to the design. but it slides from first div to last div but there are other divs between. I didn’t understand why. Can you look at this?

https://preview.webflow.com/preview/polymer-connected?preview=85347ad9d1be88685a3824b4a479dbaf

Thank’s a lot!


#2

Your sections must have a specific class that the JS is using to target them. By default it’s “section” or “fullpage”, depends of the version of the JS you’re linking to.


#3

Ah thanks @vincent. I dont know i took this js from webflow forum: Fullpage.js step by step set up

and i followed this link but it didn’t work. I don’t really know which version js is this :confused:


#4

OK

Read the post again, you need to respect the structure of divs and classes

a main div with ID fullpage
and INSIDE of it, a series of divs with a CLASS “section”


#5

Yes this is what exacly what i did. do i need to give a name to main div? i use it default but ID name of it is “fullpage” and the class names of series are “section” it slides till the end :frowning:


#7

I tried to do same thing here in new page and i still have the same problem:

http://flat-surface-shader-test.webflow.io/


#8

okay i added this js to github then it’s fixed. Thanks


#9

if you need it, there is a working clonable site available.


#10

Thanks @Dogukan_Uzak. i will try and let you know.


#11

How did you manage to disable this js on mobile?

thanks