Streaming live at 10am (PST)

Fullpage works on Webflow domain, but not my actual domain


#1

Hey all,

I’ve successfully added Fullpage.js to my site and it works great. However, when I publish to my live domain (instead of mydomain.webflow.io), the Fullpage doesn’t seem to be working.

Here’s my code (note: I spaced out the script tags so that it would appear in this post):

<script>
if(screen && screen.width > 991) {
    document.write('<script type="text/javascript" src="http://expansionscollective.com/testscripts/jquery.fullPage.js"><\/script>');
}
</script>

<script>
$(document).ready(function() {
    $('#fullpage').fullpage({
    css3: true,
    autoScrolling: true,
    fitToSection: false,
    fitToSectionDelay: false,
    scrollBar: true,
    easing: 'easeInOutCubic',
    easingcss3: 'ease',
    animateAnchor: true,
    loopBottom: false,
    loopTop: false,
    loopHorizontal: true,
    continuousVertical: false,
    continuousHorizontal: false,
    scrollHorizontally: false,
    interlockedSlides: false,
    resetSliders: false,
    fadingEffect: true,
    normalScrollElements: '#somesectionsID',
    scrollOverflow: false,
    scrollOverflowOptions: true,
    touchSensitivity: 5,
    normalScrollElementTouchThreshold: 15,
    bigSectionsDestination: null,
    });
});
</script>

Not sure, but is it to do with the SRC?

Thanks


#2

try changing the protocol of the script to https.


#3

I’ve tried changing src="http://expansionscollective.com/testscripts/jquery.fullPage.js to src="https://expansionscollective.com/testscripts/jquery.fullPage.js but it didn’t seem to work. You’re right that my domain is https though.

EDIT: I got this working, I changed http://expansionscollective.com/testscripts/jquery.fullPage.js to https://cdn.rawgit.com/alvarotrigo/fullPage.js/master/jquery.fullPage.js and it works great. I guess this is what you meant by changing the protocol of the script to https, but for some reason this was marked as ‘solved’, but not by me – which should certainly not happen, because my issue was not solved.

Thanks for your help though!


#4

Ah, the host where the script is located on doesn’t support https. Try using a CDN instead:

https://cdnjs.com/libraries/fullPage.js


#5

Yep I had already said that this was sorted - I used https://cdn.rawgit.com/alvarotrigo/fullPage.js/master/jquery.fullPage.js

Appreciate the help though!