Streaming live at 10am (PST)

Get rid of white margin on top of page with transparent navbar

#1

Hi everyone,

I want my navbar to be semi transparent and sticky. For some reason this only seems to work on the “home” page. On every other site, there is a white margin on the top of the page. What am I doing wrong?

Also, when you click on a navbar link on the published webflow.io site, the link stays light blue on the page that then loads. Does anyone know how to change this? Or is it only my browser?

Thanks already for your help! :slight_smile:


Here is my public share link: LINK
Here is the link to the webflow.io page:LINK

#2

It looks like you fixed the transparent nav? To change the blue current nav link, simply change the text colour of the current state menu link.

#3

Unfortunately not. As I said, for some reason I only have the problem on every other site, but not the home page. It might just be my browsers though (brave and safari) - I haven’t tried it in chrome yet.

Also on the screenshot you can see the issue with the navbar link that stays blue. It’s not that I haven’t changed the text colour (my navbar is a symbol, which I use on every page). I’ve changed both hover colour normal state colour the dark grey you can see on all the other links. My hover effect is that the links slightly move up when the cursor hits them. But when you click on a navbar-link on the home page, for example, the link you clicked on appears blue on the page that then loads.

#4

Other pages previewed ok in chrome, but the live site may be different.

The blue text link is webflow default link text. The text colour for the nav link in the style panel is not appear blues it should but you need to change it anyway.

1 Like
#5

I’m not sure I understand. What do you mean? What do I have to change?

#6

Your website appears to work absolutely normal in chrome. Have a look in chrome.

1 Like
#7

I seem to have the same issue with chrome. The links stay blue once you clicked on them and there’s this white margin on the top.

#8

Ok. I’ve fixed the blue link issue - seems to have been a bug. Thank you though! :slight_smile:

Any idea how to fix the white margin?

#9

Change Navbar from sticky to fixed.

1 Like
#10

OMG Thank you!!! I’m such an idiot. Thanks!

1 Like
#11

Haha! Don’t worry about it. Have fun!