Streaming live at 10am (PST)

Getting 404 for non www site - pushing to the two separate sites creates via Webflow, creates duplicate content, according to search engines


#1

Goddady keeps insisting there should not be 2 ip address.

They are open to a 3 way call

www.abstaktconrete.com - working

abstraktconrete.com - not working

Godaddy is open to a 3 way call...me being in the middle between Webflow and Godaddy is not working

Does anybody else use Godaddy as the domain provider and Webflow for hosting?

Best,

Nathan


#4

Hey @nathanphilsteele sorry for the trouble with setting up your DNS settings on your GoDaddy site, can you please try the following?

Try following the directions available here:
https://help.webflow.com/article/how-to-point-your-godaddy-domain-to-webflow

The two IP addresses are necessary to make sure your site stays up 99.9% of the time, we serve up sites on both servers to help with load balancing. ​Please let me know if this is helpful, if not, I'm happy to help further. :slightly_smiling:


#5

Hi @Waldo,

I've got it setup like that line for line. I've shown Godaddy that page as well, and they verified that the configuration is setup exactly on that page.

Since I've been through this a couple of times now, Godaddy wants to speak directly.

If you would like, I would be happy to provide you the Godaddy info in a private email so you can validate the info and correspond directly with Godaddy.

Best,

Nathan


#6

Hi @nathanphilsteele, Thanks for following up on this - I took a peek and noticed that the site isn't published to your naked domain:

Also, you can set a primary domain that all other custom domains can forward to by clicking the "house" icon next to the domain name:

Let me know if this resolves it for you! :slightly_smiling:


#7

Hey @nathanphilsteele could you please send me a link to your Webflow.io subdomain site so that I can look into this further?

Thanks in advance!


#8

I just recently setup a site the other day through Webflow and Godaddy DNS. Everything is working perfectly and I had no issues. It was per Webflow instructions.


#9

Hi @thewonglv,

SEO audits show that doing it that way publishes the site as two separate sites...very bad for seo due to duplicate content.

Best,

Nathan


#10

Hi @Waldo,

Here is my site: https://preview.webflow.com/preview/bluelakecreative?preview=68cfbfda25786cb12e08e263487bbcaa

Best,

Nathan


#11

Hi @thewonglv,

SEO audits show that doing it that way publishes the site as two separate sites...very bad for seo due to duplicate content.

Best,

Nathan


#12

So if I am not wanting to publish to essentially two separate sites due to the big seo ding for seo I will receive from doing so with the search engines, especially Google, what other alternatives do I have? Thoughts? @Waldo @thewonglv

Best,

Nathan


#13

I found this, but it looks like something that has to be done on your guys side - https://www.quora.com/How-do-I-redirect-a-non-www-request-to-www-in-GoDaddy

Thanks in advance


#14

I got it resolved. @Waldo @thewonglv

Here was the resolution:
* Delete the two IP address asked to be installed on the godaddy instructions.
* Add a forward 301 redirect rule to www.yoursite.com

Let me know if you need any further detail in how I got it resolved while keeping my seo safe :blush:

Best,

Nathan


#15

Hi @nathanphilsteele

This is the Webflow way:

Site settings > Hosting > Custom Domain

Click on the home icon next to the trashbin icon to set a default domain. This will make all the other variants redirect to the main one. Simple.


#16

Very simple, indeed

Thank you! @samliew


#17

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.