Streaming live at 10am (PST)

Glitch within CMS, Editor Mode

Hello Team,
this is the first time I’m using Webflow for a company blog. I have a few glitches to report and a few grievances:

  1. it’s a complete mystery but in Edit Mode (not when I’m within the Blog Post collection) as a Collaborator, whenever I click within the container of the post body (let’s say I want to correct a typo), it automatically opens a link that I referred back to in one of the articles. This happens even when I’m in a completely new article that I’ve just posted, it still redirects me to that one link I somewhere mentioned in a prev. article. The whole blog is a work-in-progress, I’ll need to scrap and redo it again, but this seems like a bug. Otherwise, the Edit mode has a very nice UI, my other collaborators liked it, too. Please look into this issue, though, very annoying.

  2. Within image titles, I’m not able to add a link. (Minor issue, I thought I’d share the image source directly. Doesn’t seem to work.)

  3. SOCIAL MEDIA LINKS!!! I’ve done the Open Graph settings, but I see options to share the blog post on social media absolutely nowhere within the Designer. This is a major feature on any blog, how is it not covered? For the time being, can anyone refer me to a very dumbed down, step-by-step process/tutorial on how to add custom code to enable direct social media sharing? (I found the one by Waldo, didn’t help, a more step-by-step breakdown would be much appreciated).

  4. I’ve figured a very roundabout way of how to show only relevant posts within a blog post category page (it’s currently disabled on the live site). However, a tutorial on what are the best practices to create these pages would be much appreciated. I want to create a dedicated page for these categories: ALL blog posts, then Category 1 (filtered), Category 2 (filtered) etc. The tutorials have mainly skipped this part, I don’t know why. Had to improvise.

That’s all. Again, my main problem is with point 1), it’s some kind of a glitch, and I’m not sure if you’ll be able to track it down from the Read-Only site as the issue doesn’t occur in the Designer.

Here is my site Read-Only:
https://preview.webflow.com/preview/marketing-page-to-go-live?utm_medium=preview_link&utm_source=designer&utm_content=marketing-page-to-go-live&preview=84e353e924352a3d1d91bf345b82ea36&mode=preview

Live site: builderspatch.com

I’m having the same problem as your 1st point with many clients… The rich text element has a bug in it. Super annoying and webflow doesn’t seem to have a fix ready yet :cry:
I’m regularly asking for this and still haven’t heard any good news on this front.

For the rest : these are not bugs :slight_smile: and for number 3 it’s easy you just use an embed component in your cms page and add the slug field to a social network sharer like this one for facebook for instance :

<a class="w-inline-block" style="width:44px; height:44px;" 
href="http://www.facebook.com/sharer/sharer.php?u=https://YOUR-URL-HERE/YOUR-CMS-SLUG-HERE" 
title="Share on Facebook" 
target="_blank" 
onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;">
</a>

Hello, @Blanca_Szabo!!

Ben here with the Webflow Customer Support Team!

It looks like @pepperclip has you covered (thanks so much)! But, I wanted to share some additional details.

  1. Yes! This is a bug. I have notified the team and it’s something they’re already looking into and working on. I can’t provide a timeline for when a fix will be available, but someone from the team will reach back out as soon as we know more.

  2. Can you share more information about this? What page are you working on? What elements are you trying to add links to?

  3. If you search through the forums here you will see a bunch of different solutions on how to accomplish this. @pepperclip has a GREAT solution above. You might also get some mileage out of using https://www.addthis.com/. We use it on the Webflow Blog.

  4. We don’t have anything around this now, but I’ll pass this feedback along to the team and see if we can come up with something for you! :smile:

Let me know if you have any other questions and I’ll be happy to assist you further!

Hey Riley, yes @pepperclip gave a clear snippet of code to use, although I didn’t clarify it: I don’t need Facebook. I need Linkedin share and Twitter share. I’m looking for them on StackExchange, trying to put the pieces together. I wonder since these custom codes are often requested, can’t you make either a blog-post or a dedicated page for these custom codes that need to be pasted in? With step-by-step instructions.

As for point 2, whenever I paste in an image within the rich text field of a blog post body, I have the option to give it a title (you know, some text below the image). I cannot seem to make that text into a hyperlink. It’s not a problem right now, just thought I’d play nice and refer directly to the photographer’s page (on Instagram, Unsplash etc.).

Hey @pepperclip, thanks for the help :slight_smile: Adding it to the slug field seems simple enough. Now I just have to look for the ‘sharer link’ of other social media sites, right? I’ll try to implement it and come back if stuck somewhere.

Linkedin & Twitter :

<a class="w-inline-block" style="width:44px; height:44px;" 
href="http://www.linkedin.com/shareArticle?url=YOUR-URL/YOUR-SLUG" 
title="Share on Linkedin" 
target="_blank" 
onclick="window.open(this.href, 'linkedin-share','width=580,height=296');return false;">
</a> 


<a  style="width:44px; height:44px;"
onclick="window.open(this.href, 'twitter-share','width=580,height=296');return false;" 
class="w-inline-block"
target="_blank"
href="http://twitter.com/share?url=YOUR-URL/YOUR-SLUG&via=YOUR-HANDLE"
>
</a>
1 Like

Oh, awesome! Thank you, @pepperclip!!!

Hey, @Blanca_Szabo!

​Ben here with the Webflow Customer Support Team!

​I wanted to let you know that our team recently pushed out a fix for this issue and you shouldn’t be experiencing this anymore.

​I want to thank you again for your patience as we worked to find a solution for this.

​If this doesn’t resolve your issue, please reach back out and I’ll be happy to assist you further!