Streaming live at 10am (PST)

Google Ads disapproved as landing pages returning 301


#1

Our Google ads, which have been running for years have suddenly been disapproved due to Destination not working. I’m fairly certain it’s due to an invalid http status code as per their policy page at https://support.google.com/adspolicy/answer/6368661?hl=en-GB#673
(Under Destination not working, click on Troubleshooter: Destination not working)

One of the landing page URLs Google doesn’t like anymore for example is https://www.simplyadverse.co.uk/lp/mortgages-for-bad-credit

I ran fiddler on this and it shows the above url and other disapproved destination urls returning a 301 status code. There are no redirects setup for that page, so I’m a bit stumped.

I’d really appreciate any help on this as we need to get the ads running again fast. Thank you.

Graham


#2

Hi @webflow

I’ve just had this feedback from Google Adwords. It’s not 301s but 302s and 304s causing the issue.

From Google:

The ads are getting disapproved again and again as there is an issue with the developer tool which come up as 302 and 304 error.

Kindly speak with your web developer to remove any kind of off domain redirection and get back to us.

I would really appreciate some advice on this please because our ads are still disapproved and I’m not sure how to fix this, or even if it’s an issue on Webflow’s end. Please can you advise me asap. Thank you.

Graham


#3

I had a similar issue once and repasted the same url and when adwords scanned it was fine.
I am interested in knowing what caused this in the first place so I’ll follow this discussion.


#4

Thanks for your feedback @chloecan. We’ve still got hundreds of disapproved ads. @webflow, can you shed any light please? Thanks


#5

Hi @webflow

I’ve submitted a support ticket for this and still had no reply. I’d really appreciate a response please about the 302/304 http response code errors as we need to get to the bottom of it urgently.

Thank you.

Graham


#6

While Google Ads does officially allow their ad links to be redirected - an HTTP 200 response code will work much better. It may be worth noting that the display URL does not need to match exactly the advert destination URL.

Perhaps you have ommitted the www. out of your destination URL? Your site currently redirects with an HTTP 301 code to the www subdomain if it has been omitted.

Try making sure the sudomain is correctly entered into the landing page destination.


#7

Hi @cjroe

Thanks for your reply. I have checked and the destination url always references www. That was one of the things I wondered it could be as I noticed the 301 that caused, hence the post title. Google have come back to say it’s 302 and 304’s that are the problem though. They won’t tell me anymore than that, which isn’t particularly helpful.

I’ve no idea why 302s are happening. 304s seem to indicate a caching issue https://httpstatuses.com/304. I wonder if @webflow might be able to advise. All the content is static and rarely changes. Perhaps I can add a header caching code to the head or something. I’m not a techie so need some advice or explanation of the exact cause and how to fix it if anyone can help.

Thanks.


#8

Hi @GrahamCox, thanks for your question on the strange report from Google. I ran a test on the url you provided but am not seeing any redirects:

HTTP/1.1 200 OK
Server: openresty
Date: Fri, 12 Oct 2018 07:04:18 GMT
Content-Type: text/html
Content-Length: 25569
Connection: keep-alive
Via: 1.1 varnish
Accept-Ranges: bytes
Via: 1.1 varnish
Age: 0
X-Served-By: cache-iad2147-IAD, cache-sea1020-SEA
X-Cache: HIT, MISS
X-Cache-Hits: 1, 0
X-Timer: S1539327859.513214,VS0,VE73
Vary: Accept-Encoding

When I checked the non-https url, the result is:

HTTP/1.1 301 Moved Permanently
Server: openresty
Date: Fri, 12 Oct 2018 07:06:12 GMT
Content-Type: text/html
Content-Length: 182
Connection: keep-alive
Location: https://www.simplyadverse.co.uk/lp/mortgages-for-bad-credit

Which is correct as the 301 properly redirects to the https url.

When I do a redirect from https://simplyadverse.co.uk/lp/mortgages-for-bad-credit:

HTTP/1.1 301 Moved Permanently
Server: openresty
Date: Fri, 12 Oct 2018 07:05:19 GMT
Content-Type: text/html
Content-Length: 178
Connection: keep-alive
Location: https://www.simplyadverse.co.uk/lp/mortgages-for-bad-credit

This also looks correct as the root domain will do a 301 redirect to the www domain on https.

I cannot find any issues in the redirects, there must be some other external factor that Adsense is complaining about, you might do the same test, but first remove all non-google custom code used on the site that might be introducing some redirects.

It would also help if you can take a screenshot of your Network tab of the browser console when navigating to the page, that will show the redirects:

Here is what I see on the url using the network tab of the console:

The results from the network console match my terminal checks. I hope this info helps, if you can get specific info from Adwords on the requests that are ending in 302, 304 redirects, I would be really interested to see that info.

Thanks in advance,
Dave


#9

Hi @cyberdave

Thanks very much for taking the trouble to look at this for me.

I think I’ve found the issue running https://www.simplyadverse.co.uk/lp/bad-credit-mortgage through the network console produces 302 and 304 response codes for a zopim chat file called https://v2.zopim.com/?2X4uDDQNa07FTbyKzdmRSkYg9aepAhiu and a trustpilot widget file called main .js

Which is slightly worrying because I’m not sure this will be quickly fixable by Zopim and Trustpilot. But I’ll contact them and see.

Many thanks for your help, it’s really appreciated.

Graham