Streaming live at 10am (PST)

Google font only shows italic on Safari


#1

Hi,

I added Raleway from Google Fonts in non-italic weights from 100 - 900 and it works totally fine in chrome as well as on mobile.

Only on Safari (desktop version) text is shown in italic. The only exception is when font weight is 400 (regular) or 700 (bold), even in the editor.

Has anybody made the same experience or even has a solution?

That’s my page: https://www.bitsandpretzels.com/

Thx


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Hi @Lollo

Thanks for posting, this definitely sounds like odd behavior.

I took a look at your live site in Safari – on this end all fonts appeared non-italic. Here is a screenshot of what I see on this end:

If you are seeing that italic font on your end can you please send me screenshots of the behavior you’re describing?

Could you please let me know what browser version you’re using by sending me your information from this page?

If you are not on the latest version of Safari, you may try updating to see if that helps resolve this.

Thanks in advance!


#3

Hi Brando,

Thanks for your answer. I just made an update to Version 11.0.3 (13604.5.6) but everything stayed the same. Tested on four different macs with the same outcome.

Here’s a screenshot:

I don’t think it’s a Webflow problem. It seems to be the same on other sites using Raleway.
See here:


#4

@Lollo that’s super strange for sure!

I don’t think it’s a Webflow problem

I think you’re right on that. I did some digging and found a possible solution that may resolve the issue for you.

Can you please try taking these steps to see if this resolves the issue:

Open Font Book (Cmd + space; type ‘Font Book’)

Option A: Disabling / enabling fonts

  • Disable all fonts, if that resolves the issue, then
  • Enable fonts one by one until you figure out the problem font
  • Delete the problem font

Option B:

  • At Font Book, select “File” -> “Restore Standard Fonts”

Please let me know if this helps to resolve the issue :slight_smile:


#5

Hi,
You have been right. I checked my font booked and found out that Raleway had only been installed in italic, Regular and Bold. That’s totally confusing as I’ve been working with all styles in InDesign and other programs for years and it has been the same on several macs across the company.

Nevertheless you solved it. Thanks a lot. Great service!


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.