Streaming live at 10am (PST)

Google font variants added doesn't appear in the designer

Hi folks!

When I add more weight variants to Poppins font (Google font) select it them from the project settings, they doesn’t appear in the designer.

I reload the designer, I published the website, I delete cookies and that navigation data, I delete it the font and added again, but I can’t make it work.

Can you help me?

Hi @Neogravity_Tech thank you for posting this, this definitely sounds like odd behavior.

What sites are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please?

Can you please try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: Browse in private - Computer - Google Chrome Help

If that doesn’t resolve the problem, can you please contact our Support Team so that we can troubleshoot this and find a resolution together?

Thank you so much!

Hi Waldo,

I did it in incognito mode and it doesn’t work.

This is the link:
https://preview.webflow.com/preview/ottoslatinpalace?utm_medium=preview_link&utm_source=designer&utm_content=ottoslatinpalace&preview=9344a30c97f3db111feffc95ab64a61c&mode=preview

Un saludo.

Neogravity Team

Hi @Neogravity_Tech thank you so much for following up!

I’m having trouble reproducing this behavior on a new site on this end. :thinking:
Shared with CloudApp

Can you please send me a screenshot of what happens when you add the Poppins font with each respective font weight selected under your fonts tab?

A workaround in case the native functionality isn’t pulling through would be to download the Poppins font weights from Google fonts directly and upload those font files to your site.