Streaming live at 10am (PST)

Google Maps Embed: We couldn't find that address error

Hey Webflow fam,

I have been having an issue with my Google Maps embed on a dental website redesign I have been working on. I have the API key made and restricted to the HTTP referrers (websites). I know the API is working as it is currently in use in client’s current website but in webflow design mode, when I enter in the address, I get We couldn’t find that address error.
image

I have researched quite a bit here and the only thing I have not done yet is creating a new API just because with the API working on the current website, I ruled it out.


Here is my site Read-Only: Westview Dental

2 Likes

I’m having the same problem. IT hasn’t been an issue with any of my other sites. Did you manage to find a fix?

Still having the same issue. I was hoping someone on the forum could help me out with this.

I’m having the same issue.

Asking the team to look into this immediately — this is definitely unexpected behavior.

1 Like

Hi, @imtiazraqib, @Kieran_Hall, and @AmDizzi — sorry about that! Can you refresh the Webflow Designer try the addresses in the Maps element again? Our team has rotated API keys, and this may have been caught up in that process. :crossed_fingers:

Hey @McGuire,

Unfortunately, I am running into the same issue as seen here.

image

Hey!

The issue still persists here, unfortunately. Thanks for your help.

Sorry about that, @imtiazraqib and @AmDizzi — our team has been working hard to resolve this, and we’ve now verified it’s functioning correctly on our end. Can you try again to validate? :pray:

2 Likes

Perfect @McGuire, the embed is working now! Thank you so much! :smiley:

1 Like

Works great! Thanks for your help :smile:

1 Like

Can you please tell me how you resolved this? I am still having this same issue.