Streaming live at 10am (PST)

Google Optimize install not recognized - Please help!

Hey Community,

Like many times before, I am using Google Analytics for tracking and Google Optimize to run an A/B test.

  • I added the Analytics ID to my projects settings
  • I added the Optimize ID to my project settings
  • I saved my project settings
  • I published my site
  • I do not have any custom code on this site

Here is a screen recording showing all of this:

However, Google Optimize is saying the following:

Does anyone know why Optimize is not being recognized?

Here is my read-only and published website.

Thank you!

Edit: @vincent and @mattvaru any advice? Sorry for the tags, just really stuck :slight_smile:

Hey! No worries. I’m away from my computer right now (and I unfortunately have no experience with Google Optimize), but I’ll check this out as soon as I can.

1 Like

@mattvaru Thank you!

Your read-only link is broken. Can you share again?

Edit: Also, which method did you use? https://support.google.com/optimize/answer/7513085

Edit 2: I’m also guessing you tried the troubleshooting steps listed here, correct? https://university.webflow.com/article/integrating-google-optimize

@mattvaru - Sorry about that. While publishing I unpublished and republished which I thinks breaks my previous read-only links. I turned the read-only link back on!

Also, yes I did try all of the troubleshooting tips with no luck :frowning:

Edit - also, I am not sure if this helps, but here is another screen recording showing some of the things I have tried too:

  • Adding the integrations under the projects settings
  • Adding the Optimize + Analytics code snippet to site-wide code
  • Adding Optimize + Analytics code to the individual pages

This is a stretch and I have strong doubts it works, but have you tried disabling Global site tag (gtag.js) and seeing if it works?

I have tried it both ways with no luck womp womp

1 Like

:pensive:

This may be out of my wheelhouse in terms of troubleshooting, though I’m sure the lovely folks over at Webflow HQ would actually be of better assistance than I. Sorry I couldn’t be of more help!

1 Like

No worries at all, man - I appreciate you checking it out though! I emailed Webflow earlier and hoping for a reply. Thanks again for taking a look!

1 Like

@mattvaru The @webflow support team was able to help like you suggested. It ended up being all my fault and not a bug as I had uBlock Origin installed, which blocks ads but also Optimize’s javascript too :slight_smile: Thanks for the suggestion!

1 Like

Great to know for future users, and glad you got it solved! uBlock Origin is very popular so I’m sure other devs / designers / marketers will need to know this.

1 Like