Streaming live at 10am (PST)

Google Sheets to Webflow CMS Zap Not Working

I am having trouble with a Zap from Google Sheets to the Webflow CMS. Essentially, the CMS requires a “slug” but for some reason when I run the Zap with the website I have I receive

"We had trouble sending your test through.

The app returned “‘fields.slug’ invalid input”. This usually happens when your Zap is missing a required field or a field value isn’t in a recognized format."

I’d love to get rid of the need for the slug but I dont think thats possible. Is there another way to make this work? More than willing to get more detailed if necessary. I assume it’s an easy fix, I just haven’t been able to figure it out yet.

what is the value that you’re passing as a Slug through Zapier?

1 Like

Honestly, Im not sure what to put. I’ve tried my webflow webpage name (https://diversifyingsuccess.webflow.io/), i’ve added the collection name after the slash but honestly not sure where to go from here.

Should it be different for every entry?

Any advice would be appreciated.

Exactly. The slug should be unique for each one of the items inside a collection list. Example: my-blog-post-04 . Remember , this will be part of a link so don’t use special characters, spaces and etc.

If you’re still unsure , go inside a project in Webflow and add an item to the collection list, you’ll understand what the slug in a CMS item means

1 Like

Ok, I understand now but now Im not sure if what I am trying to do will work. It definitely use work but it seems this slug part is new to the collections list.

I am following this tutorial (https://www.makerpad.co/tutorial/job-board-in-webflow). I am trying to make a job board. The way its supposed to work is you fill out a form on typepad, those answers are put onto a google sheet with zapier then those answers come from that google sheet and are inserted into the CMS with zapier.

The problem is there is no way to get that slug into the google sheet (at least I dont think)… especially since it changes everytime.

Is there a way to get rid of slug being a requirement on my CMS list?

Or a way to have the slug insert correctly into my google sheet?

i figured it out. For anyone who sees this and runs into a similar issue.

Dont change the name from “slug” to something else :man_facepalming:t6:

1 Like