Streaming live at 10am (PST)

Google Tag Manager - has anyone done this successfully?

Hi All, for some reason I’m having trouble getting GTM installed. Has anyone done this successfully? Every old forum post has incomplete answers or solutions that no longer work.

I have tried the following:

  1. Inserting it in the global custom code header and footer
  2. Adding an Embed element on every page in order to add the code as high in the tag as possible
  3. Removing the comments in the custom code

Anyone had any luck or can point me in the right direction? Thanks!

Not sure if it matters, but here’s the read only link: https://preview.webflow.com/preview/octane-test?utm_medium=preview_link&utm_source=dashboard&utm_content=octane-test&preview=52081ad6abc7adbbaf5d22cb6518e45b&mode=preview

Here’s a test site: https://octane-test.webflow.io/

Did you follow the tag manager installation guide ?

That’s correct! I added that tag in an embed element (didn’t work) and in the global footer code (didn’t work either). Followed this tutorial, but didn’t work: https://webflow.com/blog/integrating-google-tag-manager-with-google-analytics-in-webflow

No need for embed. You need to add one snipet into the head section and the second snipet to the footer like so:

That’s how I did it the first time (and how it currently is on site) but it didn’t work. I just tried the embed option once in order to follow the Google instructions of 'pasting the code as high in the tag as possible.

what do you mean by it didn’t work ?

Good question. The code is technically on the page but Google Tag Assistant isn’t showing that it’s running nor is Chrome Inspect showing that it’s executing.

By doesn’t work, he means that it does not conform to the requirements for Google Tag Manager. You can use Tag Manager Assistant chrome plugin to verify if GTM is working.

The issue is with the that needs to be added immediately after the tag. This is a requirement for GTA. So…

  • Adding to the footer will never work, it’s not where the GTM snippet goes
  • Adding as an embed, the “custom code” is wrapped in a
    tag, thus breaking the GTM requirements for following the tag.

    There seems to be now way to accomplish this today, as the forum has many people having this same issue.