Streaming live at 10am (PST)

Grid auto-fit problem

Hi there. New to webflow. seems to work great and fast!
I have a problem with a grid. I am not able to use the auto-fit grid and i can’t find the problem.
tryed to delete all the FR or VH or % values. But the problem still exists.

auto-fit

Hey @6907

Here’s an excerpt from Webflow University about the subject.

Enable Auto-fit
Auto-fit is one of the most powerful features of CSS grid, it allows you to repeat and wrap columns automatically so that you can build a layout that works across every single screen size — no per-breakpoint adjustments needed.
To enable auto-fit, delete all but one column and one row. Set minimum and maximum dimensions for the column and enable auto-fit.

The article and videos are a great resource if you’re just starting with grid.

Also, welcome to the community! :partying_face:

Hi @6907,

Could you share a preview link to your site and possibly share a screen recording of your steps? It would help us to see where the issue lies and take steps to help resolve it for you.

1 Like

Thanks but the problem is solved. Grid 2.0 in webflow explained all.

Hey @magicmark - I recently got the DevKit template and I think the issue I’m having is related to this post. All the grids seem to be messed up and waaaaaaay down the page. I’ve been through the documentation you referenced in this thread but still can’t figure it out.

Any ideas? It seems like a setting is just off, but I can’t find it.

Read only link:
https://preview.webflow.com/preview/interstory?utm_medium=preview_link&utm_source=designer&utm_content=interstory&preview=ef8b25c63316296773d0a689017c049d&pageId=5ecb93112ecbe8209ee16377&mode=preview

The page on that Preview link has been deleted.

In the meantime, try clicking the Hide Empty Elements button in the bootm left hand side of the designer.

1 Like

Ok, let me try that first. Thanks!

Oh, yes! Amazing. I knew it was something small I was missing. Thank you so much!

1 Like