Streaming live at 10am (PST)

Grid on mobile exceeds screen

Coming from Wordpress, I have to say I’m having a hard time designing with Webflow.

I’m building a portfolio with pictures and already went to the trouble to manually setup multiples breakpoint because it didn’t sync to sync automatically. Now I can’t find a way to make the grid work in mobile the way I intend it too.
First I would like the pictures to place themself automatically in the grid and if I set Auto, it keeps expanding the number of columns (which I certainly don’t want in mobile).
Second, I don’t understand why my 4 columns don’t fill the screen, they’re 1FR each.

Thank you.

Hi @Deborah_D,

Perhaps you’ve set the Grid Child position manually on a column size larger than your grid settings, this will cause the grid to auto generate columns.

You can share a read only link so I can dive deeper into your concern.

In addition you can always refer to the tips and tricks from Webflow university to get into Grid layout :slight_smile:

Cheers,

Lucas

That’s actually what I’ve figured overnight ! Thanks for your help, it raised other issues but I’ve addressed them in another topic.

1 Like