Streaming live at 10am (PST)

Hamburger menu - can close menu by clicking anywhere in the navbar?


#1

Hi Guys,

I have a small issue. My menu operates fine but when in tablet view down I click the hamburger menu to open the menu, works correctly - if I click again it closes, great. However, if I open the menu and then click anywhere in the navbar it closes the menu but leaves the hambuger icon rotated. Is there a way to disable clicking anywhere in the navbar to close the menu and force you to have to use only the hambuger icon.

I have attached a video showing what I mean and also attached the ready only preview.

Hoping @Brando can help me again… :grinning:
Thanks John


Ready Only Preview

Link To Video


#2

Hi @webleeds thank you so much for reaching out about this interaction, great question!

Typically this is resolved by using a Navbar Menu Open and Close interaction. I made a quick video to walk you through:

CloudApp

Please let me know if this is helpful or if you have any additional questions.

I’m happy to help further! :bowing_man:‍♂️


#3

Hi @Waldo

Thanks for your swift reply. I have done that but it is like before, if you open the menu, once opened you can close it by clicking anywhere in the navbar, you don’t have to click the hamburger menu which is ideally what I would like.

It has stopped the icon not returning back to start position though which is great!

Thank you

John


#4

Hi @webleeds thanks again for reaching back out!

Everything I’m seeing is expected behavior, if I click a link in the nav menu while it’s open. Then I navigate to the appropriate destination and the navbar closes as expected.

If I click around the empty space below the buttons, the navbar does not close (which is expected).

Are you seeing something different on your end? Perhaps another quick video would be very helpful to describe the issue?

If so, could you please let me know what browser version you’re using by sending me your information from this page?

There should be a small share link when you visit the page which you can send to me.

Thanks in advance!


#5

Hi @Waldo

It’s cured - not sure waht happened but I totally started the navbar from scratch and all is great now thank you.

John