Streaming live at 10am (PST)

Hamburger Menu Not Opening in Safari on iPhone

not sure if this is a bug… but my hamburger menu works fine in preview and on my resized desktop browser but when i try to open it on my actual device (iphone 6) using safari nothing happens. no menu appears on click. however using the mobile chrome browser it opens fine.

live site: http://selfpubweekly.com/
share link: https://preview.webflow.com/preview/selfpubweekly?preview=9dcb2af0b10aef1b7f91e08b7049010a

Hm on my iphone6 the hamburger menu seems to be doing fine.
p.s. you really have to tap exactly on the icon itself.

Image:

thanks! i have tapped pretty hard and no dice. what iOS are you on? i am on iOS 9.1. i contacted support too and they said it is working fine for them on iOS8. so i am trying to figure out is this is isolated to newer versions of the iOS.

Hm also using iOS 9.1 :confused:

and the browser you are using is safari and not chrome? the issue for me is only in safari. chrome works fine.

Hey @dapitts08 try setting your navbar height to auto instead of 50px on mobile :slight_smile:

thanks @waldo. i made the change but still no difference on my end.

They both do their job fine on my device

Hey @dapitts08 which iPhone are you using? I’m on an iPhone 6 and the menu is working perfectly in Chrome, Safari & Opera.

iphone 6. weird. when i click it flashes but the menu doesn’t open :confused: i cleared my cache to see if that is the issue too. i’m stumped.

got it. thanks so much for your help :smile:

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.