Streaming live at 10am (PST)

Having Trouble Implementing CMS Multi-Image Field

Hi Community,

I am working on a website for a custom home-builder, and I am having trouble implementing the multi-image field for a CMS item. Before I forget, here is my read-only link, and here is the link to the live staging site.

To begin, below is the design I am going for. The 4 images on the right-hand side are currently static.

Ideally, the 4 images on the right hand side of this collection item would be sourced from the CMS multi-image field. I do have that set up in my CMS Collection as you can see below:

However, I have not found a way to connect to the multi-image field. The section itself is a collection list where only a single item is displayed, and it’s based on whether a CMS toggle is featured on or off for a featured listing. You can see that it’s a collection item below:

I cannot connect a BG image to the multi-image field as it’s not an option, and you can see below. I can only choose to source it from “Card Image” which is a single image CMS field.

So, I started to look around for other solutions, and I figured the Lightbox Gallery would be the correct solution. I found this person ( @meteorites ) doing exactly that. Here is his read-only link. He is placing a lightbox inside multiple collection items and then sourcing the background image from his multi-image field in the CMS. You can see this below:

So, I went and followed his exact setup, but I still cannot choose my multi-image field to get the BG image, just like he did. You can see this is not a selection from the image below:

Anyways, I am sure I am doing something stupid, and I am hoping someone in the community can point me in the right direction to accomplish my design above. To sum everything up, I am trying to keep the same layout from my design (one main image and 3 side images), I am trying to pull the BG images from the multi-image field in the CMS, and ideally, I would like to limit the number of items from the multi-image field shown to 4.

Thanks for any help you can offer :slight_smile:

UPDATE:

I messaged @Meteorites as he went through this same problem on the forums, and he pointed me back to the following video. Starting at about 33 minutes, I see that the Webflow team is showing this working on a CMS page, not a normal page where a CMS Collection List is added. I am now wondering if this is the reason I can’t connect to the multi-image field. Is it true it must be on a Collection Page?

UPDATE 2: Diving deeper into the forums, I did find one person (@sarahfrison) saying this can only be done on collection template pages, not static pages where cms collections lists are added, see below:

3 Likes

I do have the same problem.
I mean this would be horrible if there is no work around. In which way should I create a dynamic gallery?

1 Like

Hi @myonke,

You guessed correctly. I just added the lightbox to a dynamic collection page and you could then select the multiple images. (pic attached).

With my project I added a main image to a static page and then clicked through to view all the images that were being pulled in via lightbox multiple images. Perhaps this could work for each house? Just a thought.

Hope this helps

All the best

Matt

Thanks again for the follow up. I did try this, too - was just hoping I was still doing something wrong haha. Can you explain this work around a little more? Not completely following haha

“With my project I added a main image to a static page and then clicked through to view all the images that were being pulled in via lightbox multiple images. Perhaps this could work for each house?”

Hi, Apologies, I just re-read what I wrote.

@myonke I added individual images being pulled in from the cms to a static page, these connected to the dynamic page where I set up the light box. So there are 2 pages in play not just one static page. So from the static it takes you to dynamic where you’ll have to then click again to see the lightbox images.

This method suited the project with the cars. You might have to have a think about site structure to achieve what you’re looking for?

1 Like

Awesome - thanks so much. I will give it a go! May come back with a few more questions though if I’m an idiot and can’t figure it out!

@myonke no worries be glad to help, I’ve had my fair share of help here on the forums, you’re close and no idiot myonke, just a slight Webflow learning curve!!

1 Like

@gaby_izarra from Webflow confirmed CMS multi-image cannot be used on a static page, but only a Collection Template Page:

Hey @myonke,
Yep! You’re right. You can only connect to a multi-image field from a CMS template page. Not a static one. We don’t support connecting to a multi-image field on static pages just yet, specifically because there isn’t a reference to the CMS item where that multi-image field lives. We are working on some nested collection features that I think is a first step toward unlocking that capability. I’ll check in with the product managers about that.

1 Like

It’s good to know @webflow is working on a solution, because it’s super inconvenient for multi-language websites!

1 Like

Hi,

I’m working on a project and for some reason I can not get my Collection to show my multi image field. I’ve added an image to the collection and no luck. Any help with is would be greatly appreciated.

Cheers,

Anfernee

ezgif.com-video-to-gif

Can you share the read-only link?