Streaming live at 10am (PST)

Header video wont play in firefox


#1

Hey guys,

For some reason my header video will not play in the firefox browser and that's the only one I seem to have an issue with. Any help would be greatly appreciated.

Preview site:
https://preview.webflow.com/preview/wereeatingbetter2?preview=d694a10632333a8b671e9fd39683f1bb

Webflow site:
http://wereeatingbetter2.webflow.io/


#2

you also need to add a webm format video in your video tag embed.

also, copy.com! I have never heard of this service! I'm going to recommend it to everyone that needs a video background or file storage for their Webflow site.


#3

Yeah they're great and free. Unlike Dropbox they won't lock you out if your link gets a lot of traffic


#4

@PixelGeek for some reason adding that file type didnt work ( so I changed it back. ) here's the code I used webflow's instruction. with the orginal video links this method works on all broswers but when I swap out the link with mine it only works in safari or chrome.

original code :

    <video autoplay loop style="width:100%; height: auto; position:absolute; z-index: -1;">
  <source src="http://syddev.com/jquery.videoBG/assets/tunnel_animation.mp4" type="video/mp4" />
  <source src="http://syddev.com/jquery.videoBG/assets/tunnel_animation.ogv" type="application/ogg" />
  <img src="http://syddev.com/jquery.videoBG/assets/tunnel_animation.jpg">
</video>

My code:

<video autoplay loop style="width:100%; height: auto; position:absolute; z-index: -1;">
  <source src="https://copy.com/rwOHKXptu03m9lab" />
  <source src="https://copy.com/W2UXwq3ZCEULQ6Y8" type="application/ogg" />
  <img src="http://syddev.com/jquery.videoBG/assets/tunnel_animation.jpg">
</video>

#5

You need to have both sources

<source src="your-video.webm">
<source src="your-video.mp4">

​Try these steps and let me know if you're successful. smiley


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.