Streaming live at 10am (PST)

Help adding a sub domain as my custom domain

Hi, there!
How are you doing?

So back in these days I’ve asked about languages translations in webflow and I find out that there is no easy way to accomplish that and, still, be able to work on SEO 100% (Links, alts, titles, etc.). So, the workaround that I’ve found and executed was:

  1. Duplicate the entire project
  2. Translate all the content needed.
  3. Add a new hosting plan for this project.

So far so good. But, to accomplish that, I’ve created a subdomain (es.example.com) where es means Spanish and I’ve added to my custom domain field. But then it returns me only a CNAME entry and no A entries. Well, I’ve input the CNAME entry and my website still doesn’t work.

Did I miss something?
Can somebody help me?

Thanks!

How much time has lapsed since you changed the records? There is generally a delay in getting those DNS changes to actually propagate – sometimes I’ve had to wait 24+ hours on a couple websites.

Hi, @mattvaru.
Thanks for your reply.

Yes. I’m aware of the DNS propagation period. But I’ve made the changes on Tuesday, so I believe it should be working for now, right?

What intrigues me is that no A entries was required. How so? For every other website that I’ve created on webflow I had to input A entries. Is that correct?

Thanks!

If you share the domain name, I would be happy to take a look for you. :slight_smile:

1 Like

Hi, @webdev.

Thank you kindly for your help! But I’ve reached the support and worked out this issue. :slight_smile:

Thank you!