Streaming live at 10am (PST)

HELP! Cannot get rid of horizontal scrollbar on the desktop

Hey Folks, no matter what I do – I cannot seem to get rid of the horizontal scrollbar showing up on the desktop version of the site. I have set overflow hidden, I have set viewport width. Someone please help!


Here is my site Read-Only: https://preview.webflow.com/preview/inspri?utm_medium=preview_link&utm_source=dashboard&utm_content=inspri&preview=027d6cc62e502fdccf28d80f42664b76&mode=preview

@Astha - no scrollbars for me in Chrome on a 16" MacBook Pro. What browser / OS are you seeing this on?

You are using 100vw as a width for your footer. Do not use 100vw - this will always result in horizontal scroll. Use 100% if you must.

This is because you did not change your default setting of “show scrollbar only while scrolling” in your mac settings. This is exactly the reason we are seeing so many sites with this small scroll - mac designers do not know that 100vw cause overflow when scroll is always visible :wink:

1 Like

@dram - good to know, thanks for the info!

1 Like

@dram - it’s gone!!! I can’t tell you how much this has been bugging me. Thank you so much :raised_hands:t3:

Not a professional web-dev, so this is really helpful for me.
-A

1 Like