Streaming live at 10am (PST)

Help! Navigation links to anchor points problem


#1

Hey guys,

what am I doing wrong?
I have the nav menu links pointing to the sections IDs, but when you click them, it takes you to a section above? (is the anchor point off by a full screen?)


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

I’m not sure what you are trying to achieve but it seems to work ok for me.


#3

Well, I guess it is harder for a non Hebrew visitor…
The links send you to the wrong anchor.

The 1st link is reloading the page - that’s ok
The 2nd one suppose to send you to where the 4 circles are - doesn’t do that
The 3rd suppose to send you to the gallery slider, but sends you to the 4 circles
The 4th suppose to send to Contact Us at the bottom, but sends you to the gallerry


#4

:sob:
nobody help me


#5

frustration… :confused:


#6

So, I am still struggling with this…
To explain better-
The right navigation bar has 4 links. I changed them to English as to where they are suppose to link to.
I have 4 sections in the page named as the links.

Why does the links always send me to one section above???


#7

So I believe this is simply an issue of not setting up your site correctly. You must insert a tag ID for the sections you wish to link to. For link 2, you have no destination set. For number 3, you have it linking to some element within the circles, and the same for the 4th. I suggest reworking your site structure and naming your IDs to your sections themselves and then choosing them from the link within page dropdown.25%20PM


#8

Thank you for the answer!
I am afraid it is not the case :slightly_frowning_face:
I constantly keep changing and trying stuff, so I might have deleted or changed that specific link.
Here is the published site:
http://almogly-2-0.webflow.io/


#9

It doesn’t matter. Just select your sections, add Div IDs and then link your menu links.


#10

I appreciate your help.
The DIV’s have IDs, and the menu links are connected. you can see so in the site or the screen capture I uploaded.
Still, something is off.


#11

Your site structure is really strange. I honestly am not sure how to help you.


#12

What would you change structurally?
How would you advise me to build it better? :smiley: