Streaming live at 10am (PST)

Help please : / Hover over elements not being recognised?


#1

Hi guys, just started a new site in Webflow and have borrowed some style from the business page tutorial (the parallel galaxy at the end), and I’m trying to add some interactions when I hover over the milkyways on the page (I intend on these being animated and becoming mini links to more info)… but it doesn’t seem to recognise the elements I’m hovering over. I’m sure I’m missing something simple, any ideas?


Here is my site Read-Only: https://preview.webflow.com/preview/hyperwolf?preview=cf8ef8cd45aa11515853ba21e0f30b36


#2

It’s because the image “clouds” is over top of everything. Instead of making a huge image block with position absolute just make a div with everything inside it and set the background image of the div to cover and make it the clouds image you want. If you want it more zoomed in just changes the width and height to greater that 100%.


#3

Thanks! Will I be able to achieve the same depth and parallax effect this way? I’ll check it first thing in the morning when I’m on the computer


#4

Yep! !n the background image settings you can set it to fixed.


#5

Where does this leave the other cloud layers though? I added all cloud layers to a new div (you’re right, the clouds were covering my access to the milky ways) but i can only use one cloud layer as background image…?
Ive re ordered the layers in the Navigator tab so they are above the clouds div but the clouds still block them… don’t get it


#6

and when i delete the clouds and put in a fresh div each, setting them to cover, they either too small or they still stop me being able to hover on the milky way elements


#7

Any other ideas? Cant seem to get this to work