Streaming live at 10am (PST)

Help required: Portfolio items not displaying in preview - glitch


#1

Hi there,

I bought a premium theme and am currently customising it to make my portfolio website. My public read only is here: https://preview.webflow.com/preview/joseph-s-amazing-site?preview=21fd78c2906326f96a0fe1497563d77d

When I press the preview button and scroll down to the portfolio section, nothing appears. It just glitches a little but no portfolio items show up?

Any idea of whats going on? Your help would be much appreciated. Thanks!

Please see screenshots.



#2

Hello @jjgoldman

The reason for that is because you can't add interactions to a dynamic item so you just need to wrap everything inside a Div Block and give the interaction to that div block instead of the dynamic item.

Check this out:

and add the interaction to that div:

and you're good to go!

Cheers,


#3

Thanks a lot @aaronocampo. That seemed to do the trick... However, now when clicking the portfolio items they don't open... any thoughts on this?


#4

Also @Waldo, any thoughts?

Thanks in advance guys!


#5

@jjgoldman for some reason your link block it's not working properly, follow these steps:

  • Put the "Portfolio Item Title" and "Portfolio Item Description" inside de "Portfolio Div"
  • Move "Portfolio Div" out from the "link block"
  • Delete that "link block" and add a new one
  • Put the "Portfolio Div" inside that new Link Block and set the link to "Current Portfolio" and that should be it.

I noticed that the moving up interaction is gone so just make sure that when you apply an interaction is set to an element on not the dynamic item.

Let me know if that helps.

Cheers,


#6

Thanks for the help. Thank worked!


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.