Streaming live at 10am (PST)

Hidden Dropdown Menu content (in Nav Menu)

#1

Hello everyone!

I’m having a big issue with my dropdown buttons (“Activity” and “ES/EN”) in my top Nav Menu.
Their content (the drop down list of links) remains hidden behind… everything (a Div, slider, anything!).

I thought I’d tried it all (Z-index, Overflow, etc.) to solve the problem, but I guess I didn’t as it persists…

You can check it out here:
https://preview.webflow.com/preview/exploramunt-com?utm_source=exploramunt-com&preview=ce07b493df99bb37585047a108afd263

I would be really grateful to anyone who could help me solve this puzzle.
Thank you in advance for your help!!!

Rob


Here is my public share link:

https://preview.webflow.com/preview/exploramunt-com?utm_source=exploramunt-com&preview=ce07b493df99bb37585047a108afd263

(how to access public share link)

#2

Hello my friend.

I think I’ve figured it out. You didn’t allow overflow, both in the Navbar Section as in the Columns div. Here are a couple screenshots of what elements I’m talking about, and how the overflow settings should be.

41
65

Please, expand this last image so you can see the overflow settings

I hope I helped you. Have a good day!

#4

1m

Hello Jeandcc,

Thank you so much as it did help!!!

Still, now I seem to have another issue… in the back-office, the dropdown menu remains open, when it should be closed, and when I set it to open, half (the vertical half) of the dropdown menu turns… invisible. Moreover, in the preview, it doesn’t work on hover as it should…
I’ve placed a link in the main text that controls/activates the dropdown… could that be the issue? I’ve tried to remove that link, but couldn’t.

Do you think that you could help me out again? I hope you can!
I believe that you can still access the website…

Thank you again for everything :wink:

1 Like
#5

That’s probably the issue. It doesn’t make much sense putting a link on a drop-down trigger, because originally you want that text to open the drop-down menu instead of opening a totally different page.

What I would try to do is simply create a new drop-down from scratch. It’s not gonna take a lot of effort, so I really recommend you doing so. Avoid reusing elements from the drop-down that is showing problems

Let me know if it works. And please, don’t delete this post, so other people can get the help they need if they encounter a similar problem to what you found

#6

Hello Jeandcc,

Thank you, OK then I’ll give it a try and I’ll keep you posted!

Thx again!

#7

No problem! Let me know how things go

#8

Hello Jeandcc!

Now everything seems to work out fine in terms of Nav menu. Feel free to go check it out.

Again, thank you so much for your help!!!

Have a great day :wink:

1 Like
#9

Great to know I could help. Have a great week

Happy Designs!

1 Like
#10

Jeandcc,

Just one more question… I’m building a multi-llingual website and I need to change the language of common elements such as the Nav Menu or the footer according to the language of the page they sit in… any suggestion on how to that (as I believe that all nav elements are site wide interconnected)?

Thx again!!! :wink:

#11

PS: for example, could I duplicate the Navigation and Footer symbols, then rename them, adapt the texts to the new language, and finally place them in the right pages?

#12

That’s bascially the simplest way to do it (And the only one I know so far). It would just like creating a new website, but you have everything already designed, so now you only need to change the texts inside them.

Duplicating and adjusting is the most straight-forward approach to it.

Just remember to create 2 symbols for each element. One for the English version of the website and then one for the Spanish version I believe.

I’m glad I could help. Feel free to get in touch

#13

Thank you Jeandcc!

So far so good. Now I have two additional issues:

  1. I have several CMS Collections. For instance, one of them is “Posts” (which was already included in the package I chose) and “Viajes (ES)” (that I’ve created from scratch, presenting a selection of Trips). I have an issue with that… Every list of “Posts” (latest, featured, etc.) has every single Post clickable. When you click on one of the Posts, you end up on the Template page of that specific Post. I supposed that my “Trips (ES)” list would work the same way, but unfortunately it doesn’t. My Viajes in all the Collection List are not clickable and I do not see what I should do to make them clickable, so that they’d lead the user on the specific Viaje template page (“Viajes (ES) Template”). Could you help me out with that…?

  2. Another issue, still related to CMS Collections. As I was saying, I have created a CMS Collection with a list of trips (“Viajes (ES)” ) and another CMS Collection with a list a activities (“Actividades (ES)”). I have cross referenced the two collections so that some trips correspond to a specific activity (for example, 5 trips could match the Climbing activity). Now, when building the Actividades (ES) template page, I thought I could enter a Collection List of these pre-selected trips (Viajes), but I cannot. If I enter a Collection List for the Viajes (ES) in the Actividades (ES) template page, ALL of the Viajes are included in the list. How could I only show these Viajes that match the Actividad, on its specific template page?

Please let me know if you can still access the preview and thank you again in advance for your help !!! :slight_smile: