Streaming live at 10am (PST)

Hidden menu shows up on page load

On page load, my dropdown overlay menu shows up on the screen for like a millisecond before disappearing. It shouldn’t show up at all unless the hamburger icon is clicked on.

Any ideas on why this is happening?


Here is my public share link: LINK

Hello @jeffjeanbap,

I didn’t see your dropdown menu at all on page load only when i clicked on it. Does this happen on the published site only? could you share the published link?

Hey @Pablo_Cortes

Weird. I’m on chrome and it shows up in the preview link https://digitalsauce.webflow.io/

I just published this yesterday also here. https://www.thedigitalsauce.com/

Note: I am not seeing this on mobile (safari or chrome)

@jeffjeanbap,

I don’t know for sure, but I think what is causing your problem is your menu wrapper symbol. Shouldn’t it be display none and then when clicked on the nav bar menu change to display flex? I’m sorry I can’t test this since I can’t publish it, but I think that could help. Let me know if it does.

Success! Initially, when I was troubleshooting, I set display: none in the initial state interaction and the end to Flex. The issue was still showing. Then I set the element itself as the default state. That worked.

Thanks @Pablo_Cortes

1 Like

That is awesome @jeffjeanbap, Im glad it worked out for you. Good job on the website too, it looks great and I really like that canvas interaction you have. Take care.

1 Like

I appreciate that @Pablo_Cortes . Thank you!