Streaming live at 10am (PST)

Hide Nav Scroll Bar


#1

Hey guys–

Hope all is well! Wanted to see if someone could help me hide the nav scroll bar I have set up across my site. Basically, it’s initial appearance his hidden when you scroll, it appears as you scroll down, and then if scroll back up all the way on the page you’ll notice it appears for a user.

Would be great if someone could let me know what’s going on here. Haven’t been able to identify this one. Appreciate the help.

https://preview.webflow.com/preview/trytootles?preview=2eff3d1cfdee00cffd0a22814633a76c


#2

Looks like you fixed it huh?


#3

No I wish! It happens on Chrome still.

You have to display the nav bar triggered by scroll, and then scroll all the way up. Strange issue. Any thoughts?


#4

Hmm… I’m using Chrome and on the site now… Tell me the exact steps because it’s going away like it should for me. Are experiencing flutter/shuttering or what?


#5

Basically, once it appears and you scroll back up to the top of the page…keep scrolling further up and you’ll see what I’m talking about. It’s almost like a force scroll past the top.


#6

Dude… I’m thinking I need a specialist or something. On my browser it is perfect and nothing is showing back after I scroll up. It disappears completely everytime.

On which element is the Display Nav Scroll?

Also, log into another workstation if you’re at the office; or another computer at home.


#7

Hi @jose_llorens

Looks like you have everything set up correctly except for one small piece.

On the Display nav scroll interactions, it looks like on the scroll out of view is set to display: block instead of display: none.

I hope this helps! :slight_smile:


#8

Thanks for the help!

However, when I tried that the nav menu now doesn’t appear at all on scroll. Let me know if you get a different result. That didn’t work for me…

Appreciate the time.


#9

@jose_llorens

I just realized I had your interaction turned around a bit — apologies!

You will need to edit the scroll into view part of the interaction to display: none. Here is another gif

Hope this helps!


#10

You’re a legend! Worked perfect.


#11

So…this is now happening on mobile (Safari) after that edit. Not sure why, but let me know your thoughts if you have a chance or have any suggested solutions. Not sure if it was that previous solution that triggered this, but yeah been stuck on this one now haha.

It’s only happening on the “What’s Included” pages for mobiles.

Appreciate the help! Looking forward to hearing from you.


#12

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.